aboutsummaryrefslogtreecommitdiffstats
path: root/testing/whois/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-12-06 09:21:49 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2015-12-07 14:56:25 +0100
commitafcd87ab650c232075855d98518e249b829d8309 (patch)
tree8ad8a4c0378180e5e058651e88d726fa3b62e844 /testing/whois/APKBUILD
parent5a9e98255debfd2a6d63d10527307dca05dd4b53 (diff)
testing/whois: new aport
Marco d'Itri's whois client.
Diffstat (limited to 'testing/whois/APKBUILD')
-rw-r--r--testing/whois/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/whois/APKBUILD b/testing/whois/APKBUILD
new file mode 100644
index 00000000000..bc7267b0925
--- /dev/null
+++ b/testing/whois/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=whois
+pkgver=5.2.10
+pkgrel=0
+pkgdesc="Intelligent WHOIS client by Marco d'Itri"
+url="http://www.linux.it/~md/software/"
+arch="all"
+license="GPLv2"
+makedepends="$depends_dev perl libidn-dev gettext-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make CONFIG_FILE="/etc/whois.conf" \
+ HAVE_LIBIDN=1 HAVE_ICONV=1 \
+ CFLAGS="$CFLAGS -lintl $CXXFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make BASEDIR="$pkgdir" install-whois || return 1
+ install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
+}
+
+md5sums="19579468bdb311eed5c6b8c3216cce1b whois-5.2.10.tar.gz"
+sha256sums="8169bead001fb68d14f09a49c117d3408d48a3378f3a67eb0e56848a637ad54e whois-5.2.10.tar.gz"
+sha512sums="c3280d62329035c12cc69dd45986d32fd9c858efa9b2d8674cb8208429c1eb35dfcb50aaab442215e5c3321cbb1fc4ecabff7058c38da2db8fb5f0aac61429c2 whois-5.2.10.tar.gz"