aboutsummaryrefslogtreecommitdiffstats
path: root/testing/winetricks/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-04-27 15:57:24 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 17:44:49 +0000
commitc9bce320ca16c3c907e49927f712c61ed6b08139 (patch)
treed9544d7f774c1a7be978c0e88d14cd16930578cf /testing/winetricks/APKBUILD
parentc784630154d5906f913aca4a180dde29354a0f4a (diff)
testing/winetricks: upgrade to 20190310
- Modernize - Add bash-completion subpackage Closes GH-7384
Diffstat (limited to 'testing/winetricks/APKBUILD')
-rw-r--r--testing/winetricks/APKBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/testing/winetricks/APKBUILD b/testing/winetricks/APKBUILD
index 6683aff955c..30368a2dcf8 100644
--- a/testing/winetricks/APKBUILD
+++ b/testing/winetricks/APKBUILD
@@ -1,34 +1,27 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
pkgname=winetricks
-pkgver=20170101
+pkgver=20190310
pkgrel=0
pkgdesc="Winetricks is an easy way to work around problems in Wine"
-url="http://winetricks.org"
-arch="all"
+url="https://winetricks.org"
+arch="x86 x86_64" # Limited by the wine pkg
license="LGPL-2.1-or-later"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
-subpackages="$pkgname-doc"
+options="!check" # Missing depends bashate & shellcheck
+depends="cabextract unzip wine xmessage"
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/Winetricks/winetricks/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$builddir"
+package() {
+ make DESTDIR="$pkgdir" install
}
-build() {
- cd "$builddir"
-}
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
}
-md5sums="0227e0ed0d9ff6b150676a060b1b6c8f winetricks-20170101.tar.gz"
-sha256sums="3862ce2d94132484cb7fced13ccef6a7d1e94d75b5ee96b269d1bc45309f7b49 winetricks-20170101.tar.gz"
-sha512sums="537566e62e91814775bd81c817125f9bc924e40f9db874275453db03c244f9bcab9cc82e77f027a90338656e1193601fd638623bad853502d2ef9d07b306eb66 winetricks-20170101.tar.gz"
+sha512sums="4f08228306a84cd2e1ecf0df46e951dfc5844716fadab903eca7ed09f15ed2bbba7ca5bf48384f934783be6a85b812129427a296a580561ee5b8483df0e64025 winetricks-20190310.tar.gz"