aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wldash/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-09-15 00:53:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2021-09-15 00:53:56 +0200
commit161ad028cee35b57bf96ce26b6e982afaf1e6820 (patch)
tree5b47340ec42ebcd312701f7dae6771fbceaecf49 /testing/wldash/APKBUILD
parentd977c555f5dd0e988c1d7b3c142461278484c3c0 (diff)
testing/wldash: disable on aarch64, armhf, armv7, ppc64le due to failure
Compiling fontconfig v0.2.0 error[E0308]: mismatched types --> /home/buildozer/.cargo/registry/src/github.com-1ecc6299db9ec823/fontconfig-0.2.0/src/lib.rs:185:43 | 185 | let cstr = CStr::from_ptr(ret as *const i8); | ^^^^^^^^^^^^^^^^ expected `u8`, found `i8` | = note: expected raw pointer `*const u8` found raw pointer `*const i8` error[E0308]: mismatched types --> /home/buildozer/.cargo/registry/src/github.com-1ecc6299db9ec823/fontconfig-0.2.0/src/lib.rs:281:45 | 281 | let fcstr = unsafe { CStr::from_ptr(fcstr as *const i8) }; | ^^^^^^^^^^^^^^^^^^ expected `u8`, found `i8` | = note: expected raw pointer `*const u8` found raw pointer `*const i8` error: aborting due to 2 previous errors For more information about this error, try `rustc --explain E0308`. error: could not compile `fontconfig` To learn more, run the command again with --verbose. warning: build failed, waiting for other jobs to finish... error: build failed
Diffstat (limited to 'testing/wldash/APKBUILD')
-rw-r--r--testing/wldash/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/wldash/APKBUILD b/testing/wldash/APKBUILD
index bfe021c3898..a3a5d917914 100644
--- a/testing/wldash/APKBUILD
+++ b/testing/wldash/APKBUILD
@@ -6,7 +6,9 @@ _gitrev=5e5e8876f6dbecaf508045f400b63097ddccef6b
pkgrel=0
pkgdesc="Wayland dashboard/launcher/thing"
url="https://github.com/kennylevinsen/wldash"
-arch="aarch64 armhf armv7 ppc64le x86 x86_64" # limited by rust/cargo
+# aarch64, arm*, ppc64le: fails to build due to fontconfig crate
+# others: limited by rust/cargo
+arch="x86 x86_64"
license="GPL-3.0"
makedepends="
alsa-lib-dev