aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wpan-tools/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-06-30 15:46:37 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-30 15:20:10 +0000
commit9778591e24b525017799f1925944485527b59911 (patch)
tree087cc7815b76cf5ca87166dda72a1137ce5973a2 /testing/wpan-tools/APKBUILD
parent312400ea6c03b09d2c3685760e32761f0172088e (diff)
testing/wpan-tools: new aport
Diffstat (limited to 'testing/wpan-tools/APKBUILD')
-rw-r--r--testing/wpan-tools/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/wpan-tools/APKBUILD b/testing/wpan-tools/APKBUILD
new file mode 100644
index 00000000000..9d1a75add25
--- /dev/null
+++ b/testing/wpan-tools/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=wpan-tools
+pkgver=0.7
+pkgrel=0
+pkgdesc="Configure and test 802.15.4 devices"
+url="http://wpan.cakelab.org/"
+arch="all"
+license="ISC"
+depends="libnl3-dev linux-headers"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://wpan.cakelab.org/releases/wpan-tools-$pkgver.tar.xz"
+builddir="$srcdir/wpan-tools-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7a44ec620bfc27428e73074146604638a33e6b705d8109bd6314d6086f5c1b364932ce400c4c1a295bdcd976eeae9a1ed9da1bbc75981f8824beeeb4cd3c5511 wpan-tools-0.7.tar.xz"