aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xf86-input-wacom/APKBUILD
diff options
context:
space:
mode:
authorIvan Tham <pickfire@riseup.net>2017-03-16 18:53:41 +0800
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-16 15:33:51 +0000
commit7da4e0efc8372ec248d94b64225da8b4ecbde7ae (patch)
tree9983c6dff75528eb9c72411244a5189ff34ee47a /testing/xf86-input-wacom/APKBUILD
parentc7821f69d591034e7b0fcb13c7cf38ba09b1b61d (diff)
testing/xf86-input-wacom: new aport
http://linuxwacom.sourceforge.net/ X.org Wacom tablet input driver
Diffstat (limited to 'testing/xf86-input-wacom/APKBUILD')
-rw-r--r--testing/xf86-input-wacom/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/xf86-input-wacom/APKBUILD b/testing/xf86-input-wacom/APKBUILD
new file mode 100644
index 00000000000..2feeafdc326
--- /dev/null
+++ b/testing/xf86-input-wacom/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=xf86-input-wacom
+pkgver=0.34.2
+pkgrel=0
+pkgdesc="X.org Wacom tablet input driver"
+url="http://linuxwacom.sourceforge.net/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="xorg-server-dev libxext-dev libxi-dev libxrandr-dev
+ libxinerama-dev eudev-dev"
+checkdepends="bash findutils"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/linuxwacom/$pkgname/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+check() {
+ cd "$builddir"
+ make check || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="882a72c90838ad0cba1386629ac307adac69ed30d7bd3dcbd0cfa5d80c177eceeb09675eda45f01c61e726136f894bb3dda3f2b9b4b195287b6fcb4b00214c8e xf86-input-wacom-0.34.2.tar.bz2"