summaryrefslogtreecommitdiffstats
path: root/testing/xfburn
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-18 17:44:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-18 17:44:27 +0000
commit950ea5721e9f82d5efb62677e9d0145525e366da (patch)
tree8c23f0f79e6ba4299b32b7580c3b3b45114dc3e3 /testing/xfburn
parentdaeee3280bd26c32211863ff3a8a3e718aa51b64 (diff)
testing/xfburn: new aport
a simple CD/DVD burning tool based on libburnia libraries http://goodies.xfce.org/projects/applications/xfburn
Diffstat (limited to 'testing/xfburn')
-rw-r--r--testing/xfburn/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/xfburn/APKBUILD b/testing/xfburn/APKBUILD
new file mode 100644
index 00000000000..fabe3877312
--- /dev/null
+++ b/testing/xfburn/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfburn
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="a simple CD/DVD burning tool based on libburnia libraries"
+url="http://goodies.xfce.org/projects/applications/xfburn"
+license="GPL2"
+depends="desktop-file-utils hicolor-icon-theme"
+makedepends="libburn-dev libisofs-dev libxfcegui4-dev thunar-dev librsvg-dev
+ gst-plugins-base-dev exo-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://archive.xfce.org/src/apps/xfburn/${pkgver%.*}/xfburn-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-gstreamer \
+ --enable-thunar-vfs \
+ --enable-dbus
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="147cdc2d909e751125be16103b8dc81f xfburn-0.4.3.tar.bz2"