aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xfce4-sensors-plugin/APKBUILD
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-07-30 22:53:08 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 08:31:43 +0000
commitd0a68398da16b576e986d5b83a617b24527e5990 (patch)
tree15739c68b1f24d205b8dcfb8d3a8328924238f31 /testing/xfce4-sensors-plugin/APKBUILD
parenta4ac09c55d22da3a65e46433c63545bf6bf75e10 (diff)
testing/xfce4-sensors-plugin: move back from unmaintained and upgrade to 1.2.98
Diffstat (limited to 'testing/xfce4-sensors-plugin/APKBUILD')
-rw-r--r--testing/xfce4-sensors-plugin/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/xfce4-sensors-plugin/APKBUILD b/testing/xfce4-sensors-plugin/APKBUILD
new file mode 100644
index 00000000000..d85aacdb263
--- /dev/null
+++ b/testing/xfce4-sensors-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=xfce4-sensors-plugin
+pkgver=1.2.98
+pkgrel=0
+pkgdesc="Reads your hardware sensor values and displays them in your panel"
+url="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+arch="all"
+license="GPLv2"
+depends_dev="xfce4-panel-dev lm_sensors-dev libxfce4ui-dev"
+makedepends="$depends_dev bash"
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6437acc17d2719e3deef011c206c8c5593f4b14a8263e82bb3b0e8b1cb7e17e842adf2cb3a479e1a8e2729db744df2778ee04bc9af5e4c918f417e1c8ac4d17e xfce4-sensors-plugin-1.2.98.tar.bz2"