aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xkill/APKBUILD
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-04-14 16:53:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-18 09:31:37 +0000
commitc153ea8b1f0b39e47b2865ba0bd38e6b10866931 (patch)
treed47bef5328ba245539d06999fbc58daec8fcdf29 /testing/xkill/APKBUILD
parentbc3a93d85d8f2ce8eb4a8c0cc59eef179563e214 (diff)
testing/xkill: new aport
Kill tool for the X Window System http://www.x.org
Diffstat (limited to 'testing/xkill/APKBUILD')
-rw-r--r--testing/xkill/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/xkill/APKBUILD b/testing/xkill/APKBUILD
new file mode 100644
index 00000000000..79d8bbe2a6c
--- /dev/null
+++ b/testing/xkill/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=xkill
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="Kill tool for the X Window System"
+url="http://www.x.org"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libx11-dev libxmu-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --datarootdir=/usr/share \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0ae6bc2a8d3af68e9c76b1a6ca5f7a78 xkill-1.0.4.tar.bz2"
+sha256sums="88ef2a304f32f24b255e879f03c1dcd3a2be3e71d5562205414f267d919f812e xkill-1.0.4.tar.bz2"
+sha512sums="14d1fc0eff96a62d66307f09efc599639ee70be4bf580e2857569326881bfdcae7a8a21640509875218dd2b88575b4801ab0c43c4295550dc71141a579483545 xkill-1.0.4.tar.bz2"