aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xml2rfc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 12:41:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 12:41:13 -0300
commit020ee9a3a8b48571172ebe432d99c88e81a69af9 (patch)
treec5553c5d73616ff621c18a77a0557fef0f91731c /testing/xml2rfc
parentebc1fa8351f35fcfe96e43e518da35fcf5f57692 (diff)
testing/xml2rfc: use py3
Diffstat (limited to 'testing/xml2rfc')
-rw-r--r--testing/xml2rfc/APKBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/testing/xml2rfc/APKBUILD b/testing/xml2rfc/APKBUILD
index 08302529287..51cd5a63c83 100644
--- a/testing/xml2rfc/APKBUILD
+++ b/testing/xml2rfc/APKBUILD
@@ -1,26 +1,21 @@
-# Contributor:
-# Maintainer:
+# Contributor:
+# Maintainer:
pkgname=xml2rfc
pkgver=2.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for converting XML documents into internet drafts and RFCs"
url="https://tools.ietf.org/"
arch="noarch"
-license="BSD"
-depends="python2 py-lxml"
-makedepends="py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$pkgname-$pkgver"
+license="BSD-2-Clause"
+depends="python3 py3-setuptools py3-six py3-requests py3-lxml"
+source="https://files.pythonhosted.org/packages/source/x/xml2rfc/xml2rfc-$pkgver.tar.gz"
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="48e79d3d00b02670261c37b60e3dfe238407a49efdfc8146e57bd5bf350877680baa1024b7f81263f6a7312e189171e37f2d77c2f7ab1754a1b1590ae02dda29 xml2rfc-2.8.2.tar.gz"