aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xorg-xinput/APKBUILD
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2015-11-15 13:07:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 09:21:58 +0000
commit7eeb4e4676da37770c8f3d773c3b17abec8b97b8 (patch)
treece68376c6cfb43d81d63dc8b8045539c89c12d10 /testing/xorg-xinput/APKBUILD
parent8b0e75ff1f56d9dcc07af9efe47e8f3c7aef0f56 (diff)
testing/xorg-xinput: new aport
http://xorg.freedesktop.org/ Utility to configure and test XInput devices
Diffstat (limited to 'testing/xorg-xinput/APKBUILD')
-rw-r--r--testing/xorg-xinput/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/xorg-xinput/APKBUILD b/testing/xorg-xinput/APKBUILD
new file mode 100644
index 00000000000..c6e78417554
--- /dev/null
+++ b/testing/xorg-xinput/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=xorg-xinput
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="Utility to configure and test XInput devices"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+depends=""
+depends_dev="util-macros libx11-dev libxext-dev libxi-dev libxrandr-dev libxinerama-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://xorg.freedesktop.org/archive/individual/app/xinput-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/xinput-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+md5sums="6a889412eff2e3c1c6bb19146f6fe84c xinput-1.6.2.tar.bz2"
+sha256sums="3694d29b4180952fbf13c6d4e59541310cbb11eef5bf888ff3d8b7f4e3aee5c4 xinput-1.6.2.tar.bz2"
+sha512sums="dbef3a87dd47bb8c593f1305bea7978697a12434a4992584e4124d745bb366812366b44fc205159137a3db6f7b8338effd1b90641a194497b19159b9fd91939e xinput-1.6.2.tar.bz2"