aboutsummaryrefslogtreecommitdiffstats
path: root/testing/yash
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-24 00:14:03 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-24 00:14:36 +0200
commit698f57190d1567def07bd4d22797b3eed921b298 (patch)
tree0bea0793ed3bd46bd76c84964fa7ff51780140ce /testing/yash
parente0448c5be0073fed5393637261699e8d7f659caa (diff)
testing/yash: new aport
http://yash.osdn.jp/ Yet another shell
Diffstat (limited to 'testing/yash')
-rw-r--r--testing/yash/APKBUILD49
-rw-r--r--testing/yash/yash.post-install3
-rw-r--r--testing/yash/yash.pre-deinstall3
3 files changed, 55 insertions, 0 deletions
diff --git a/testing/yash/APKBUILD b/testing/yash/APKBUILD
new file mode 100644
index 00000000000..7fb1c3edf3d
--- /dev/null
+++ b/testing/yash/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=yash
+pkgver=2.47
+pkgrel=0
+pkgdesc="Yet another shell"
+url="http://yash.osdn.jp"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="ncurses-dev"
+install="$pkgname.post-install $pkgname.pre-deinstall"
+subpackages="$pkgname-doc"
+source="https://github.com/magicant/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ # XXX: Disable hanging tests.
+ sed -i -e 's/\bkill[24]-p.tst\b//g' \
+ -e 's/\bsignal[12]-y.tst\b//g' \
+ tests/Makefile.in
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-nls
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ # FIXME: Fix broken tests.
+ make tests LANG=en_US.UTF-8 || true
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+ rm -Rf "$pkgdir"/usr/share/man/ja
+}
+
+sha512sums="5e1341314218ac13fcc3664b1a13a77e0c2525a0df47ee3be773f9894a5a79a1288ba55fea22ce87b70cbff8d72284cb3d11c17e989be81564c183c92ec26ecf yash-2.47.tar.xz"
diff --git a/testing/yash/yash.post-install b/testing/yash/yash.post-install
new file mode 100644
index 00000000000..e32356780fe
--- /dev/null
+++ b/testing/yash/yash.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/usr/bin/yash'
+exit 0
diff --git a/testing/yash/yash.pre-deinstall b/testing/yash/yash.pre-deinstall
new file mode 100644
index 00000000000..7205565ee1b
--- /dev/null
+++ b/testing/yash/yash.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/usr/bin/yash'
+exit 0