aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zathura-ps/APKBUILD
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-01-29 16:57:31 +0100
committerTimo Teräs <timo.teras@iki.fi>2017-01-30 16:50:11 +0000
commit3f8ade306472487f9bcf2caf59f992c5b77c9492 (patch)
treead0735a0dcda69504aec79b4210f8ffe2b72da20 /testing/zathura-ps/APKBUILD
parent265ae0af6f5b50fd0bfdb39e9956a6316697f494 (diff)
testing/zathura-ps: move from unmaintained, update
Diffstat (limited to 'testing/zathura-ps/APKBUILD')
-rw-r--r--testing/zathura-ps/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/zathura-ps/APKBUILD b/testing/zathura-ps/APKBUILD
new file mode 100644
index 00000000000..67e156e9af2
--- /dev/null
+++ b/testing/zathura-ps/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=zathura-ps
+pkgver=0.2.4
+pkgrel=0
+pkgdesc="zathura-ps - plugin adds PostScript support to zathura"
+url="https://pwmt.org/projects/$pkgname"
+arch="all"
+license="zlib"
+depends="zathura"
+makedepends="zathura-dev poppler-dev libspectre-dev"
+source="https://pwmt.org/projects/zathura-ps/download/zathura-ps-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ make -C "$_builddir" || return 1
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" \
+ -C "$_builddir" install || return 1
+}
+
+md5sums="553330eae86da48c0231f348181b9a82 zathura-ps-0.2.4.tar.gz"
+sha256sums="fb9fc7e9e7765fb0aa2935b93ff3663332d0d884df35e8d0b1ea7e4b1fa0abdb zathura-ps-0.2.4.tar.gz"
+sha512sums="c63cbd4ff032cffa85305393a8e7f2864986e3a8204832cd7f9f12878e2c69fd0393ace91dd7b0fa8829f3a785abc2675d2ecb99dfa71794d699b567be954922 zathura-ps-0.2.4.tar.gz"