aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zchunk
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-07 10:11:42 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-07 20:53:02 +0000
commitd4149a6dd83a745d80015add5898019853a26ace (patch)
treeef326a0ae0edfdb344a69a423d2e4a9aa72d1ae8 /testing/zchunk
parent745724ec9f8de9c968bb49fe74fffd125e03d543 (diff)
testing/zchunk: new aport
File format for highly efficient deltas https://github.com/zchunk/zchunk
Diffstat (limited to 'testing/zchunk')
-rw-r--r--testing/zchunk/APKBUILD47
-rw-r--r--testing/zchunk/fix-musl.patch18
2 files changed, 65 insertions, 0 deletions
diff --git a/testing/zchunk/APKBUILD b/testing/zchunk/APKBUILD
new file mode 100644
index 00000000000..a331e73025d
--- /dev/null
+++ b/testing/zchunk/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=zchunk
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="File format for highly efficient deltas"
+url="https://github.com/zchunk/zchunk"
+arch="all !armhf" # Restricted by zstd
+license="BSD-2-Clause"
+makedepends="
+ meson
+ zstd-dev
+ curl-dev
+ openssl-dev
+ argp-standalone
+ "
+subpackages="$pkgname-dev lib$pkgname:libs"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/zchunk/zchunk/archive/${pkgver}.tar.gz
+ fix-musl.patch
+ "
+
+build() {
+ LDFLAGS="$LDFLAGS -largp" \
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dwith-zstd=enabled \
+ -Dwith-openssl=enabled \
+ -Dcoverity=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="7b1d80dddb45f56c2c821599dcd2b5dd9fd971eae0b5fbc3b982450e6a17880ac4cec0889bc584311a8fdd7fb96c698d748c840399b7d714a949e1f06e2e51cf zchunk-1.1.1.tar.gz
+d35f72d42d5d00189ad732f232b8eee5a347832517229bc9272acf98edb0886a6b581c801005f61a054d70b35c457e9ca0fd3dee524958c92eaf5ea80f40d68a fix-musl.patch"
diff --git a/testing/zchunk/fix-musl.patch b/testing/zchunk/fix-musl.patch
new file mode 100644
index 00000000000..766745bb5bd
--- /dev/null
+++ b/testing/zchunk/fix-musl.patch
@@ -0,0 +1,18 @@
+--- a/include/zck.h.in.orig 2018-08-03 07:08:45.140103751 +0200
++++ b/include/zck.h.in 2018-08-03 07:09:18.613105487 +0200
+@@ -1,3 +1,4 @@
++#include <sys/types.h>
+ #ifndef ZCK_H
+ #define ZCK_H
+
+--- a/src/unzck.c 2018-08-02 15:42:19.000000000 +0200
++++ b/src/unzck.c 2018-08-04 20:20:53.438164577 +0200
+@@ -39,7 +39,7 @@
+ #include <zck.h>
+
+ #include "util_common.h"
+-
++#undef stdout
+ static char doc[] = "unzck - Decompress a zchunk file";
+
+ static char args_doc[] = "<file>";