aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRobert Boisvert <rdboisvert@gmail.com>2019-05-15 09:52:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-15 10:29:21 +0000
commit59639c312f43102dab0ad51d92580c6fbc86bfeb (patch)
tree246509266753897d2318460ae06ed25d3ab4f709 /testing
parent8b6985a8b04f7994386b5f146366ede67556ac89 (diff)
testing/hylafaxplus: address other bug with awk busybox
Diffstat (limited to 'testing')
-rw-r--r--testing/hylafaxplus/APKBUILD4
-rw-r--r--testing/hylafaxplus/common-functions-busybox-awk.patch19
2 files changed, 21 insertions, 2 deletions
diff --git a/testing/hylafaxplus/APKBUILD b/testing/hylafaxplus/APKBUILD
index 915c6fc838d..da33946cdb1 100644
--- a/testing/hylafaxplus/APKBUILD
+++ b/testing/hylafaxplus/APKBUILD
@@ -3,7 +3,7 @@
pkgname=hylafaxplus
_pkgname=hylafax
pkgver=7.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Making the Premier Open-Source Fax Management System Even Better"
url="http://hylafax.sourceforge.net"
arch="all"
@@ -95,6 +95,6 @@ package(){
sha512sums="c63fdbff79c2ced29e03907c2e401c95a739e343414840a25b9582e3f4db880eaf4622295035e4728a9d1f224f97985007944397f28c9b29595aeec157bc2031 hylafax-7.0.0.tar.gz
54025c3ee3683476fa947f1e29cda7cc61027e2cbb0be1d400c7f715b4087a5c7693e0e3f8fdb1a8ecf56f48c03e4f0d82d12a2d6ae93707b13d08569510c917 hylafaxplus.initd
a2117eddc8f0ff70a23a90f2001dcb88c5bddee46ffa021d6d1701cc5cfc3bcb0362ead2b1b1ce2b288992728053c5947466d08916649f45e7dfb1876576e50f hylafaxplus.confd
-7b8a2038d7855a169bb7dee8a96045bd9fe8ae96fe4cb2a2c60475c5d6f906bb2eff5d36c516f83ddd3e198200af542dac5b468995dd512a57bb4ed556b154eb common-functions-busybox-awk.patch
+41ae2055a7781d83fc275aafe18ced0fe75ba79d3ad7d5096eabaeae3a514b564723185dd33820268577174f6c53bfcfddb30922ba50754b15c5c3b0abbec837 common-functions-busybox-awk.patch
4a1243daff9904e6395c3e28aa4a78a74de99f5aa9dbf5055a3781acfcd9b1b3db42b1569409b27e3ef9b0e55272dc99122436a79a08c9a1c140c2547c5a2c15 no-locale.patch
f5f1e33897a91b8297311c033d50e7ea2f9088568264a5b9224285066a504da8cc4296f973dd0a70e09abca538cef26964c6181f4f67f76400783d0697f05e61 utf8-dictionary.patch"
diff --git a/testing/hylafaxplus/common-functions-busybox-awk.patch b/testing/hylafaxplus/common-functions-busybox-awk.patch
index 3e9ddd6031b..b217b20b7f8 100644
--- a/testing/hylafaxplus/common-functions-busybox-awk.patch
+++ b/testing/hylafaxplus/common-functions-busybox-awk.patch
@@ -20,4 +20,23 @@ index 38049e3..54cfd6b 100644
if [ $THISLEN -gt $ITEMSIZE ]; then ITEMSIZE=$THISLEN; fi
done
}
+@@ -146,12 +146,12 @@
+ } p("faxstatus", status);
+ next;
+ }
+- /^[!]*post/ { p("files_"++nfiles, $4); p("filetype_"nfiles, "PostScript"); next; }
+- /^[!]*tiff/ { p("files_"++nfiles, $4); p("filetype_"nfiles, "TIFF"); next; }
+- /^[!]*pdf/ { p("files_"++nfiles, $4); p("filetype_"nfiles, "PDF"); next; }
+- /^[!]*pcl/ { p("files_"++nfiles, $4); p("filetype_"nfiles, "PCL"); next; }
+- /^page:/ { p("pins_"++npins, $4); next; }
+- /^data:/ { p("files_"++nfiles, $4); next; }
++ /^[!]*post/ { ++nfiles; p("files_"nfiles, $4); p("filetype_"nfiles, "PostScript"); next; }
++ /^[!]*tiff/ { ++nfiles; p("files_"nfiles, $4); p("filetype_"nfiles, "TIFF"); next; }
++ /^[!]*pdf/ { ++nfiles; p("files_"nfiles, $4); p("filetype_"nfiles, "PDF"); next; }
++ /^[!]*pcl/ { ++nfiles; p("files_"nfiles, $4); p("filetype_"nfiles, "PCL"); next; }
++ /^page:/ { ++npins; p("pins_"npins, $4); next; }
++ /^data:/ { ++nfiles; p("files_"nfiles, $4); next; }
+ /^poll/ { p("poll", " -p"); next; }
+ # Only parse remaining valid lines and allows for colons to appear in the value part
+ /^[a-z]+:/ { str = $0; sub($1":", "", str); p($1, str); next; }