aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 22:56:46 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 22:56:46 -0600
commitefc699ce746d958120854d959272c9565b278938 (patch)
tree3bf3dcd7e4d1178ac450675cc5b5393021658816 /testing
parent54afa0049921c8d9a4b5a2aae0d5d7c28916179f (diff)
testing/libgweather: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libgweather/APKBUILD42
-rw-r--r--testing/libgweather/libgweather.post-install7
-rw-r--r--testing/libgweather/libgweather.post-upgrade7
-rw-r--r--testing/libgweather/libgweather.pre-deinstall7
4 files changed, 63 insertions, 0 deletions
diff --git a/testing/libgweather/APKBUILD b/testing/libgweather/APKBUILD
new file mode 100644
index 00000000000..7d0019a9186
--- /dev/null
+++ b/testing/libgweather/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=libgweather
+pkgver=2.30.3
+pkgrel=0
+pkgdesc="GNOME weather library"
+url="http://www.gnome.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="gtk+-dev libsoup-dev libxml2-dev gconf-dev"
+makedepends="$depends_dev"
+install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zoneinfo-dir=. \
+ --disable-scrollkeeper || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="bf6a0a05051341ecb250f332e3edfb88 libgweather-2.30.3.tar.bz2"
diff --git a/testing/libgweather/libgweather.post-install b/testing/libgweather/libgweather.post-install
new file mode 100644
index 00000000000..c9c323078a0
--- /dev/null
+++ b/testing/libgweather/libgweather.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/libgweather/libgweather.post-upgrade b/testing/libgweather/libgweather.post-upgrade
new file mode 100644
index 00000000000..c9c323078a0
--- /dev/null
+++ b/testing/libgweather/libgweather.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/libgweather/libgweather.pre-deinstall b/testing/libgweather/libgweather.pre-deinstall
new file mode 100644
index 00000000000..30dad25f8d4
--- /dev/null
+++ b/testing/libgweather/libgweather.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done