aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-22 11:05:28 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 08:53:26 -0300
commit34e2a611bc5bf2d6ac5dfa6045856f8dc3e381a0 (patch)
treee3ec32290efd63024723ab69c37b0a1e178bed3b /testing
parent869d947675bf39de32cf3b26ca6c74b58461af21 (diff)
testing/akonadi-search: rebuild against kcalendarcore
Diffstat (limited to 'testing')
-rw-r--r--testing/akonadi-search/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/testing/akonadi-search/APKBUILD b/testing/akonadi-search/APKBUILD
index fae69aa667d..f9b17f0c130 100644
--- a/testing/akonadi-search/APKBUILD
+++ b/testing/akonadi-search/APKBUILD
@@ -2,19 +2,26 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=akonadi-search
pkgver=19.08.2
-pkgrel=0
+pkgrel=1
pkgdesc="Libraries and daemons to implement searching in Akonadi"
arch="all"
url="https://community.kde.org/KDE_PIM"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="qt5-qtbase-dev ki18n-dev kconfig-dev kcrash-dev kdbusaddons-dev kcmutils-dev kio-dev krunner-dev xapian-core-dev akonadi-dev kcontacts-dev kmime-dev akonadi-mime-dev kcalcore-dev"
+depends_dev="qt5-qtbase-dev ki18n-dev kconfig-dev kcrash-dev kdbusaddons-dev kcmutils-dev kio-dev krunner-dev xapian-core-dev akonadi-dev kcontacts-dev kmime-dev akonadi-mime-dev kcalendarcore-dev"
makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/akonadi-search-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -22,6 +29,8 @@ build() {
}
check() {
+ cd "$builddir"/build
+
# akonadi-sqlite-schedulertest, konadi-sqlite-collectionindexingjobtest,
# akonadi-mysql-schedulertest and akonadi-mysql-collectionindexingjobtest
# require running dbus server
@@ -41,6 +50,7 @@ check() {
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
sha512sums="bf7d3006d03d1fda9ace33eeeb93e24263006fd6829f3e94f2932e0afa20f1cdbd859fe68227fb5602b007aab3c386803cdd458bb911774703a873975072ccad akonadi-search-19.08.2.tar.xz"