aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-25 06:21:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-25 06:22:16 +0000
commitec3fe0d3844c24ab03143b084b254e752814d80f (patch)
tree77667cd1394aaa31c2c1c310007295b5a5749374 /testing
parent78047e9031d36a594109c7831f709aefe4095757 (diff)
testing/unifdef: new aport
Tool to process C preprocessor #if and #ifdef directives http://dotat.at/prog/unifdef/
Diffstat (limited to 'testing')
-rw-r--r--testing/unifdef/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/unifdef/APKBUILD b/testing/unifdef/APKBUILD
new file mode 100644
index 00000000000..b6eae01374f
--- /dev/null
+++ b/testing/unifdef/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=unifdef
+pkgver=2.10
+pkgrel=0
+pkgdesc="Tool to process C preprocessor #if and #ifdef directives"
+url="http://dotat.at/prog/unifdef/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dotat.at/prog/unifdef/unifdef-$pkgver.tar.xz"
+
+_builddir="$srcdir"/unifdef-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make prefix=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="bb5d895e5ebbba5c5cc0c2771cf97ebe unifdef-2.10.tar.xz"
+sha256sums="3b9b2b6b1952e9b9c1b9f734edec270689a35bdbf33ae66b50e19b2ed0d2df06 unifdef-2.10.tar.xz"
+sha512sums="9537a4679997a2677dcbe26c5849147654eb20b9edbf7625bd251e065d90a3ea54c4be9d445abdbc611820d8902d446062f800313904ac3f9cde3a89120860de unifdef-2.10.tar.xz"