summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 07:02:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 07:02:52 +0000
commit598706e26976dc3937f9dcda5edac9b968784ffe (patch)
tree2719e3ef37b933aa8c73668e33eb7dbacc80632b /testing
parent13892e864cacf21636be25149eabcd3e2537f7aa (diff)
testing/luasql-sqlite3: new aport
LuaSQL driver for sqlite3 http://www.keplerproject.org/luasql/
Diffstat (limited to 'testing')
-rw-r--r--testing/luasql-sqlite3/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/luasql-sqlite3/APKBUILD b/testing/luasql-sqlite3/APKBUILD
new file mode 100644
index 00000000000..6cd89c8f0d6
--- /dev/null
+++ b/testing/luasql-sqlite3/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=luasql-sqlite3
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="LuaSQL driver for sqlite3"
+url="http://www.keplerproject.org/luasql/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev sqlite-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/luasql-$pkgver
+
+ make CFLAGS="$CFLAGS" T=sqlite3 DRIVER_LIBS="-lsqlite3" || return 1
+ install -D src/sqlite3.so "$pkgdir"/usr/lib/lua/5.1/luasql/sqlite3.so
+}
+
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"