aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-22 23:53:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-22 23:54:48 +0200
commitd09edc41584c952bd1967250f4db190dee1882a8 (patch)
treec1f89bde7701db9fcb6c994b6780316ba5bc3b8c /testing
parent947d3f601d4f5f8a9f28e8b21fbeb743a58551ef (diff)
testing/zsh-autosuggestions
https://github.com/zsh-users/zsh-autosuggestions Fish-like autosuggestions for Zsh
Diffstat (limited to 'testing')
-rw-r--r--testing/zsh-autosuggestions/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/zsh-autosuggestions/APKBUILD b/testing/zsh-autosuggestions/APKBUILD
new file mode 100644
index 00000000000..d1c3f7cc5cf
--- /dev/null
+++ b/testing/zsh-autosuggestions/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=zsh-autosuggestions
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Fish-like autosuggestions for Zsh"
+url="https://github.com/zsh-users/zsh-autosuggestions"
+arch="noarch"
+license="MIT"
+depends="zsh"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zsh-users/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ local destdir="$pkgdir/usr/share/zsh/plugins/$pkgname"
+ cd "$builddir"
+
+ mkdir -p "$destdir"
+ cp $pkgname.zsh $pkgname.plugin.zsh "$destdir"/
+}
+
+sha512sums="8404c8a0c342713620c4b0d1ad6676f891c9f7c0eb316f559b03f66fbb4349d4e2f10b625381bb026e78289a8f05a3c9d5ee102db25a4c6ea3191b854de24194 zsh-autosuggestions-0.4.0.tar.gz"