summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-02-11 23:19:47 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-02-11 23:21:24 +0000
commitc8474a0305abcbc1d0615b2952ef318fbffb3c9e (patch)
treeb85ed23e4b56cb39b1b51f6dda1fde78e983b1a2 /testing
parentcae5f98e318f2861f083f33732cd9cecc0516d15 (diff)
testing/open-vm-tools-grsec: new aport
vmware tools modules
Diffstat (limited to 'testing')
-rw-r--r--testing/open-vm-tools-grsec/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/testing/open-vm-tools-grsec/APKBUILD b/testing/open-vm-tools-grsec/APKBUILD
new file mode 100644
index 00000000000..b3b94bb4901
--- /dev/null
+++ b/testing/open-vm-tools-grsec/APKBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+_flavor=grsec
+
+# source the kernel version
+if [ -f ../../main/linux-${_flavor}/APKBUILD ]; then
+ . ../../main/linux-${_flavor}/APKBUILD
+fi
+
+_kernelver="$pkgver-r$pkgrel"
+_abi_release=${pkgver}-${_flavor}
+_kpkgrel=$pkgrel
+_realname=open-vm-tools
+
+pkgname=open-vm-tools-$_flavor
+pkgver=2011.01.24
+_pkgsubver=354108
+pkgrel=0
+pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
+url="http://open-vm-tools.sourceforge.net/"
+arch="all"
+license="LGPL"
+subpackages=""
+depends="linux-${_flavor}=${_kernelver}"
+makedepends="pkgconfig bash rpcgen automake autoconf glib-dev
+ procps-dev libdnet-dev icu-dev
+ gettext-dev linux-${_flavor}-dev=${_kernelver}
+ "
+source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_pkgsubver.tar.gz
+ "
+
+_builddir="$srcdir/$_realname-$pkgver-$_pkgsubver"
+
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ [ -r "$i" ] || continue
+ patch -p1 -i "$i" || return 1
+ done
+ # workaround automake-1.10 issue
+ # http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-found.html
+ touch config/config.rpath
+ aclocal -I m4 && autoconf && automake
+}
+
+build() {
+ KERNEL_VERSION="$_abi_release"
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-unity \
+ --without-pam \
+ --disable-multimon \
+ --without-x \
+ || return 1
+ cd "$_builddir"/modules
+ make -j1 modules || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p $pkgdir/lib/modules/$_abi_release/misc/
+ cd "$_builddir"/modules
+ for MOD in `find -type f -name '*.ko'`; do
+ install -D -m644 $MOD "$pkgdir/lib/modules/$_abi_release/misc/"
+ done
+}
+
+md5sums="b324efa55bb3f1198100cad838e9272b open-vm-tools-2011.01.24-354108.tar.gz"