summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-04 11:23:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-04 11:23:34 +0000
commitd9db4f5b4cdc2897bf30ec8d4a6696a5e174d0cb (patch)
tree91d79e02c3fce6442d65b2e0a971bada8c8a6187 /testing
parentb7e4c1252df98efa06db0f35ab9d567eb73542df (diff)
testing/igmpproxy: fix the MAXVIFS issue
This happens dues to our kernel has a patch that breaks ABI
Diffstat (limited to 'testing')
-rw-r--r--testing/igmpproxy/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/igmpproxy/APKBUILD b/testing/igmpproxy/APKBUILD
index 5c0358d90e8..a3acac70c15 100644
--- a/testing/igmpproxy/APKBUILD
+++ b/testing/igmpproxy/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=igmpproxy
pkgver=0.1_beta4
-pkgrel=0
+pkgrel=1
pkgdesc="a simple dynamic Multicast Routing Daemon using only IGMP signalling"
url="http://sourceforge.net/projects/igmpproxy/"
license="GPL"
-depends="uclibc"
+depends=""
makedepends=""
install=
subpackages="$pkgname-doc"
@@ -15,6 +15,11 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # our kernel have a patch that changes MAXVIFS
+ # note that this is ABI incompatible
+ sed -i -e 's:^#define MAX_MC_VIFS.*:#define MAX_MC_VIFS MAXVIFS:' \
+ src/igmpproxy.h
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \