summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-05 15:08:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 07:20:04 -0300
commit516fa750094a80cc99bd188e1db44395a22ccb5d (patch)
tree899f74bd129ca75f4dc2f6519940c1dbb47f7f75 /testing
parent3d0ef2b8a2d6e6b593a6cfcaee23f935636bf14c (diff)
testing/e2tools: modernize, fix url and source
Diffstat (limited to 'testing')
-rw-r--r--testing/e2tools/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/e2tools/APKBUILD b/testing/e2tools/APKBUILD
index 576eab6914e..296aac4a069 100644
--- a/testing/e2tools/APKBUILD
+++ b/testing/e2tools/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Daniel Santana <daniel@santana.tech>
pkgname=e2tools
pkgver=0.0.16
-pkgrel=0
+pkgrel=1
pkgdesc="Utilities for manipulating files in an ext2/ext3 filesystem"
-url="http://home.earthlink.net/~k_sheff/sw/e2tools/"
+url="https://e2tools.github.io/"
arch="all"
license="GPL-2.0-only"
makedepends="e2fsprogs-dev"
subpackages="$pkgname-doc"
-source="http://home.earthlink.net/~k_sheff/sw/e2tools/$pkgname-$pkgver.tar.gz
+source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
e2cp.1
e2ln.1
e2ls.1
@@ -19,24 +19,20 @@ source="http://home.earthlink.net/~k_sheff/sw/e2tools/$pkgname-$pkgver.tar.gz
e2tail.1
e2tools.7
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -dm 0755 "$pkgdir"/usr/share/man/man1
install -dm 0755 "$pkgdir"/usr/share/man/man7