aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-14 21:16:42 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit06782f9d0d29d31ac90866d738d81efbe3dd9fc3 (patch)
treec077337e7d6c13b68cd9a123e7938c059103409a /testing
parentcdba06ba0b38e4a0515d016e252180a97914772d (diff)
Initial APKBUILD for pylint
Package description: Pylint is a python tool that checks if a module satisfies a coding standard. Pylint is similar to PyChecker but offers more features, like checking line-code's length, checking if variable names are well-formed according to your coding standard, or checking if declared interfaces are truly implemented, and much more. The big advantage with Pylint is that it is highly configurable, customizable, and you can easily write a small plugin to add a personal feature.
Diffstat (limited to 'testing')
-rw-r--r--testing/pylint/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
new file mode 100644
index 00000000000..bb524faa5c7
--- /dev/null
+++ b/testing/pylint/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pylint
+pkgver=0.23.0
+pkgrel=0
+pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
+url="http://pypi.python.org/pypi/pylint"
+arch="noarch"
+license="GPL2+"
+depends="python py-logilab-astng"
+depends_dev=""
+makedepends="python-dev py-logilab-astng"
+install=""
+subpackages="$pkgname-doc"
+source="http://pypi.python.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+doc() {
+ # The man page is not picked-up automatically
+ mkdir -p "$subpkgdir"/usr/share/man/man1 || return 1
+ mv "$_builddir"/man/*.1 "$subpkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="f010eee3289b1af77cd8e8e45fb72829 pylint-0.23.0.tar.gz"