aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-02-25 22:11:14 +0200
committerprspkt <prspkt@protonmail.com>2019-02-27 20:32:43 +0200
commit0cd73d9ce169961bea2a560deb76964075e755b2 (patch)
tree69be2b08600e8822cf18345da62ff6c77ae843e1 /testing
parent49c4725efbbdcd377b1a1bc6b74f3993b8d743c9 (diff)
testing/handbrake: disable nvenc
Disable nvidia encoder APIs which are only available on x86* and therefore limit package availability.
Diffstat (limited to 'testing')
-rw-r--r--testing/handbrake/APKBUILD8
-rw-r--r--testing/handbrake/disable-nvenc.patch10
2 files changed, 16 insertions, 2 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
index 2a03b9ca9c2..af826d78050 100644
--- a/testing/handbrake/APKBUILD
+++ b/testing/handbrake/APKBUILD
@@ -20,6 +20,7 @@ source="https://download.handbrake.fr/releases/$pkgver/HandBrake-$pkgver-source.
handbrake-9999-fix-missing-x265-link-flag.patch
handbrake-9999-remove-dvdnav-dup.patch
handbrake-9999-remove-faac-dependency.patch
+ disable-nvenc.patch
"
options="!check"
builddir="$srcdir"/${_pkgname}-${pkgver}
@@ -34,9 +35,11 @@ prepare() {
build() {
cd "$builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--force \
--verbose \
+ --disable-nvenc \
--disable-gtk-update-checks
cd build
@@ -60,4 +63,5 @@ gtk() {
sha512sums="434e6db1acbe01771aeefd2f257bdc58ad84e63ba441f4977f634b9ccb3c708176b928adf1dfa9e20d4948b65876ae9b4dfdc35f9c56f03f34858380090ab29c HandBrake-1.2.2-source.tar.bz2
9ca716b290f384db839609d176b6883c4dc1aaf31206b206cfd1f29c85bb134e29fbf72bda1a8589f76e1885019dbdee5a39d8299f7f0a20a6ef8a01868f4845 handbrake-9999-fix-missing-x265-link-flag.patch
a3d57dd37d518286a62554cfcc4722d6fd588a0c3966d30785100edc4476febb2b48fc4f9b2a7eb5b5dc049043fabd4398e1e190e10cbd63c25b2936824977d3 handbrake-9999-remove-dvdnav-dup.patch
-9d070e50a9b7d4b8ac25b7d56bd341aca6dc979ba506c84f4b95109909f70020723915cd120bed24e84a8fc242ee3c3a5775f43a78b7995e53cd499444c9f6dc handbrake-9999-remove-faac-dependency.patch"
+9d070e50a9b7d4b8ac25b7d56bd341aca6dc979ba506c84f4b95109909f70020723915cd120bed24e84a8fc242ee3c3a5775f43a78b7995e53cd499444c9f6dc handbrake-9999-remove-faac-dependency.patch
+d1dbd3f884c5619efba28b5dbf4c90e7f0386cb6e7a2bb016eb5f6220207e2c1826095d7240a67861061a828da95261fdca1729de0e2359c1ee7dae66293a8c5 disable-nvenc.patch"
diff --git a/testing/handbrake/disable-nvenc.patch b/testing/handbrake/disable-nvenc.patch
new file mode 100644
index 00000000000..d062b9cefd0
--- /dev/null
+++ b/testing/handbrake/disable-nvenc.patch
@@ -0,0 +1,10 @@
+--- a/make/configure.py
++++ b/make/configure.py
+@@ -1321,6 +1321,7 @@ def createCLI():
+
+ h = IfHost( 'enable Nvidia NVEnc video encoder', '*-*-*', none=optparse.SUPPRESS_HELP ).value
+ grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=not (host.match( '*-*-darwin*' ) or host.match( '*-*-freebsd*' )), action='store_true', help=h )
++ grp.add_option( '--disable-nvenc', dest="enable_nvenc", action='store_false' )
+
+
+ cli.add_option_group( grp )