aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-07 01:33:19 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-07 01:33:56 +0100
commit0f87ce0446c82d8819c8db922e403cecc717d3e4 (patch)
treeac0d2e3375f089068a27f8c6949464b4a83f8aea /testing
parente046629b0ec42d6293b2f41606ff23199776da83 (diff)
testing/ocaml-labltk: new aport
http://labltk.forge.ocamlcore.org/ Tcl/Tk interface for OCaml
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-labltk/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/ocaml-labltk/APKBUILD b/testing/ocaml-labltk/APKBUILD
new file mode 100644
index 00000000000..19a82c221eb
--- /dev/null
+++ b/testing/ocaml-labltk/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ocaml-labltk
+_pkgname=labltk
+pkgver=8.06.2
+pkgrel=0
+pkgdesc="Tcl/Tk interface for OCaml"
+url="http://labltk.forge.ocamlcore.org/"
+arch="all !x86 !armhf !s390x" # limited by ocaml aport
+license="LGPL-2.0-or-later-WITH-linking-exception"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+makedepends="ocaml>=4.04 tcl-dev tk tk-dev"
+options="!check" # no tests provided
+subpackages="$pkgname-dev"
+source="https://forge.ocamlcore.org/frs/download.php/1628/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure --tk-no-x11
+ make -j1 all
+ make -j1 opt
+}
+
+package() {
+ local libdir="$pkgdir/usr/lib/ocaml"
+ cd "$builddir"
+
+ mkdir -p "$libdir"/$_pkgname \
+ "$libdir"/stublibs \
+ "$pkgdir"/usr/bin
+
+ make install \
+ BINDIR="$pkgdir/usr/bin" \
+ INSTALLDIR="$pkgdir/usr/lib/ocaml/$_pkgname" \
+ STUBLIBDIR="$pkgdir/usr/lib/ocaml/stublibs"
+
+ # The *.o files are not installed by the Makefile.
+ # AIUI that prevents linking with native code programs.
+ install -m 0644 camltk/*.o "$libdir"/$_pkgname/
+}
+
+dev() {
+ local sitelib="usr/lib/ocaml/$_pkgname"
+ default_dev
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+
+ cd "$pkgdir"/$sitelib
+ mkdir -p "$subpkgdir"/$sitelib
+ mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
+}
+
+sha512sums="d9342d49ba8769edd7a4ed051844f6ae5d3e62a7c2c76e895bfd1162d0433c4ea54f2314b29b708551fba63daec1123553b56f0abb6412807ab00d7bb40b73d6 labltk-8.06.2.tar.gz"