aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-14 20:03:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-14 20:03:33 -0300
commit100b9716c0cfc97a04297e602386530a7ad8cb07 (patch)
tree102ade51c5f186a44a8e506102cfb35a42cd9d07 /testing
parentae1fe924cdbd53aa8c1f0fb368fda6ea74474dcd (diff)
testing/bfs: upgrade to 1.5.1
Diffstat (limited to 'testing')
-rw-r--r--testing/bfs/APKBUILD6
-rw-r--r--testing/bfs/no-statx.patch31
2 files changed, 2 insertions, 35 deletions
diff --git a/testing/bfs/APKBUILD b/testing/bfs/APKBUILD
index f85119b1565..22b46ccee67 100644
--- a/testing/bfs/APKBUILD
+++ b/testing/bfs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: dai9ah <dai9ah@protonmail.com>
# Maintainer: dai9ah <dai9ah@protonmail.com>
pkgname=bfs
-pkgver=1.5
+pkgver=1.5.1
pkgrel=0
pkgdesc="Breadth-first variant of the UNIX find command"
url="https://github.com/tavianator/bfs"
@@ -12,7 +12,6 @@ checkdepends="bash acl"
subpackages="$pkgname-doc"
options="!checkroot"
source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/bfs/archive/$pkgver.tar.gz
- no-statx.patch
"
build() {
@@ -27,5 +26,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="13e79ce1d488f5ed9338020b1502c78cf9141ec7eceacc2fb79da23a81403b10b17c07116408dbf0b6bef7744dd547a8749d98bc485fda70665a07fac7e5f561 bfs-1.5.tar.gz
-010666234db1bae05f42288eaf4943d4677ec363e5142839c958bee0ed10d7a994bec255d9efee05d63f58e7c91e060a4ca06306aa1774bb47068daf1ef34e85 no-statx.patch"
+sha512sums="f501f2acaa19c772a350863539030c60299c3b001ebd3d473add4e8975f4fda3a79a6a524a0d1fbf729a66a943557cb66aa6d65a8aae41ab88b81a7740b17874 bfs-1.5.1.tar.gz"
diff --git a/testing/bfs/no-statx.patch b/testing/bfs/no-statx.patch
deleted file mode 100644
index b737b5e0c8d..00000000000
--- a/testing/bfs/no-statx.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 71a1b65ba926ff9c6db3cb671580b5491db0bd97 Mon Sep 17 00:00:00 2001
-From: Tavian Barnes <tavianator@tavianator.com>
-Date: Fri, 5 Jul 2019 19:11:20 -0400
-Subject: [PATCH] stat: Treat EPERM like ENOSYS for statx()
-
-On some configurations (e.g. old Docker with the default seccomp()
-profile), statx() fails with EPERM. Consider this to mean statx() is
-unsupported, as EPERM is not a documented error code in normal
-operation.
-
-Possible fix for https://github.com/alpinelinux/aports/pull/9277
----
- stat.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/stat.c b/stat.c
-index e3d5400..a2e2c8d 100644
---- a/stat.c
-+++ b/stat.c
-@@ -282,7 +282,9 @@ static int bfs_stat_explicit(int at_fd, const char *at_path, int at_flags, enum
-
- if (has_statx) {
- int ret = bfs_statx_impl(at_fd, at_path, at_flags, flags, buf);
-- if (ret != 0 && errno == ENOSYS) {
-+ // EPERM is commonly returned in a seccomp() sandbox that does
-+ // not allow statx()
-+ if (ret != 0 && (errno == ENOSYS || errno == EPERM)) {
- has_statx = false;
- } else {
- return ret;
-