aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authoralpterry <alpterry@protonmail.com>2019-12-28 18:37:42 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-28 19:44:33 +0100
commit15d534687d3a0beb913d44171d6dcd1d17dc3cbf (patch)
tree8e82963d22191df66be6e82666ece46978a3e278 /testing
parent190e2e3e5c47531a6371450c4a29e7743967a5fb (diff)
testing/perl-term-animation: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-term-animation/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-term-animation/APKBUILD b/testing/perl-term-animation/APKBUILD
new file mode 100644
index 00000000000..babcc83ef5c
--- /dev/null
+++ b/testing/perl-term-animation/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: alpterry <alpterry@protonmail.com>
+# Maintainer: alpterry <alpterry@protonmail.com>
+pkgname=perl-term-animation
+_pkgreal=Term-Animation
+pkgver=2.6
+pkgrel=0
+pkgdesc="ASCII sprite animation framework"
+url="https://metacpan.org/release/Term-Animation/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-curses"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KB/KBAUCOM/Term-Animation-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="5d2c3e18e70d19fead2a2ad2d09bfb03f3f3d569f472ea43449799c089254a14ee9c4e695d5c93bda2a30d6e7538566c16a522ceac3c747a5cf0e522f21f1e18 Term-Animation-2.6.tar.gz"