aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 06:36:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:15 +0000
commit170e14276163bfec8bbd531bc3e84e5eec94ae0c (patch)
treebe052ef609d9515776f2818e555ec84e9659c95c /testing
parent63fa2243817a942ece0d8bcca6b47d9d7fc8f86c (diff)
testing/py-repoze-lru: new aport
A tiny Python LRU cache implementation and decorator https://pypi.python.org/pypi/repoze.lru
Diffstat (limited to 'testing')
-rw-r--r--testing/py-repoze-lru/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-repoze-lru/APKBUILD b/testing/py-repoze-lru/APKBUILD
new file mode 100644
index 00000000000..8940331c1a7
--- /dev/null
+++ b/testing/py-repoze-lru/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-repoze-lru
+_pkgname=python-stdnum
+pkgver=0.6
+pkgrel=0
+pkgdesc="A tiny Python LRU cache implementation and decorator"
+url="https://pypi.python.org/pypi/repoze.lru"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="dca61638f8c9a6f1ff56225e873d0990 python-stdnum-0.6.tar.gz"
+sha256sums="7061886cf33e72a4b2b6594e5455fa38e45ea586d719f334e097dfb4ae971eda python-stdnum-0.6.tar.gz"
+sha512sums="5afe969e94b99ec7ea4cf163b75a1eeab8c6ce4c233502e97edb569d3ab643bf6cc309aa4497ed56653ae4927b089c062d747a5db3a448bd77fdd47aaa6c63c9 python-stdnum-0.6.tar.gz"