aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-23 17:20:42 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-23 17:21:04 +0200
commit184d781b84f7990b784ec89f1d5fac34c51e0ee4 (patch)
tree4e6831174f52727e33e53872d4182ad4aadf0aa7 /testing
parentfb9e9288077b1d5604a582bc23c510846011a73e (diff)
testing/xfce4-calculator-plugin: new aport
Calculator plugin for the Xfce4 panel https://goodies.xfce.org/projects/panel-plugins/xfce4-calculator-plugin
Diffstat (limited to 'testing')
-rw-r--r--testing/xfce4-calculator-plugin/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/xfce4-calculator-plugin/APKBUILD b/testing/xfce4-calculator-plugin/APKBUILD
new file mode 100644
index 00000000000..591f5012f69
--- /dev/null
+++ b/testing/xfce4-calculator-plugin/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-calculator-plugin
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="Calculator plugin for the Xfce4 panel"
+url="https://goodies.xfce.org/projects/panel-plugins/xfce4-calculator-plugin"
+arch="all"
+license="GPL-2.0"
+makedepends="xfce4-panel-dev libxfce4ui-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="cf5a1005d03163a2b44440bd2ac3a40ae2bf5d217893cb11e96b83ccdf621195dd38f315e762d1edc7570c9fde5568a1517f4e3abe6f9c74daa6c027e276c2c9 xfce4-calculator-plugin-0.7.0.tar.bz2"