aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-01 21:05:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-01 21:05:50 -0300
commit1c120af754d773924b37c0d2ce02789af4631ba8 (patch)
tree732d0b4bc6548413d9c8d2b2b8f1a3d7cc9708a1 /testing
parentef7cb4509fd1564ddc282b97f5ddeefdebd1a432 (diff)
testing/py3-eliot: new aport
https://github.com/itamarst/eliot Logging system that tells you why it happened
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-eliot/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-eliot/APKBUILD b/testing/py3-eliot/APKBUILD
new file mode 100644
index 00000000000..a2e1fa7257e
--- /dev/null
+++ b/testing/py3-eliot/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-eliot
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="Logging system that tells you why it happened"
+# Requires unpackaged dask and cffi for testing journald
+options="!check"
+url="https://github.com/itamarst/eliot"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-zope-interface py3-pyrsistent py3-boltons
+ py3-twisted"
+makedepends="py3-setuptools"
+checkdepends="py3-hypothesis py3-testtools py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/itamarst/eliot/archive/$pkgver.tar.gz"
+builddir="$srcdir/eliot-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="946acdc3bc6063b4a17cb7af3fefb3db04c3fce539db50405470fca892de4972e320d44ef1bcb832e5acc8d4c848fe4270dedc99b434085caa2e7c5fa4648d17 py3-eliot-1.10.0.tar.gz"