aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-08 13:21:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-08 13:21:40 +0000
commit28004e62cb14c545e7866dd5ac9b020ba28c64e4 (patch)
treee21c52bb534d2aa38c7e4c720e0cedd42cbb050f /testing
parentc3db9cef255232c447e66f8c63c4fa138d6cf024 (diff)
testing/lxd: upgrade to 2.17
Diffstat (limited to 'testing')
-rw-r--r--testing/lxd/APKBUILD14
-rw-r--r--testing/lxd/lxd-dont-go-get.patch18
-rw-r--r--testing/lxd/lxd.confd8
3 files changed, 28 insertions, 12 deletions
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
index 28306752f07..b66eb7d29d3 100644
--- a/testing/lxd/APKBUILD
+++ b/testing/lxd/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lxd
-pkgver=2.16
+pkgver=2.17
pkgrel=0
pkgdesc="a container hypervisor and a new user experience for LXC"
url="https://linuxcontainers.org/lxd/"
arch="all"
license="Apache-2.0"
-depends="acl xz netcat-openbsd cgmanager squashfs-tools rsync shadow-uidmap lxc ip6tables dnsmasq"
-makedepends="lxc-dev protobuf-dev rsync go gettext-dev"
+depends="acl xz netcat-openbsd cgmanager squashfs-tools rsync shadow-uidmap lxc ip6tables dnsmasq ca-certificates"
+makedepends="lxc-dev protobuf-dev rsync go gettext-dev linux-headers acl-dev"
install="$pkgname.pre-install"
options="!check"
source="https://linuxcontainers.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz
+ lxd-dont-go-get.patch
$pkgname.confd
$pkgname.initd"
_project="github.com/lxc/lxd"
@@ -24,6 +25,7 @@ prepare() {
# copy src to project directory to replace the symlink
rm -f dist/src/"$_project"
rsync -a . --exclude="dist" dist/src/"$_project"
+ default_prepare
}
build() {
@@ -31,7 +33,6 @@ build() {
export GOPATH="$builddir/dist"
#https://github.com/lxc/lxd/issues/496
export CGO_LDFLAGS=-lintl
- go build -v -work -x "$_project"
make -C dist/src/"$_project"
}
@@ -48,6 +49,7 @@ package() {
"$pkgdir"/etc/conf.d/lxd
}
-sha512sums="b143bb1bc82ecb0751e3e20a10d363ef393a37d455f6dff99d4c60103336b35f752348f063c47df6b7eff0f08dfa0c06c235b1426084e4be56b470b91a5a0f3c lxd-2.16.tar.gz
-7f1fdacacf8bdab49d3a932c41d52aa84b0df5e0fa3d8e67758902ae70b99b23eb0a9e869cc0d06b30ca711b0f3e18ac5dfa9aad2f43d2cf1fda1eb8353c6ba0 lxd.confd
+sha512sums="e30b2893e1f581e4774e3055a738d086175c0d3f35038d900daca5b37e7aed75bf33035dfbde58da14d3cc5d7895f5a3748608151ee0f0a14e084b86e5fda34f lxd-2.17.tar.gz
+e2c0c96d0efc33e459cf14365f01d60b73ed03f028d36ca5ea27cd647f5d2a91ec61bcf2723437f7b930aec6ebabac3697e0e3adc6b2918817833c9f182aab49 lxd-dont-go-get.patch
+bc32c71f2ce10f508433e1e4651c08c18e8a17e9419a7ce391c0f127fc7cf378c665178926b35eae8813e290d9c5eab3ceb605679fd32efdf2cf98a57cee4127 lxd.confd
94de0c0d5ab63463a929a4151359950b1117d0ada5ccf0944311cc70c6b6d4c437ccb4158734ab35db67bfb4abc437074c3f3515be4531f63adc74da21fefb5b lxd.initd"
diff --git a/testing/lxd/lxd-dont-go-get.patch b/testing/lxd/lxd-dont-go-get.patch
new file mode 100644
index 00000000000..506e56b9568
--- /dev/null
+++ b/testing/lxd/lxd-dont-go-get.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index 3a0cc01..1d54c9d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,13 +13,11 @@ TAGS=$(shell test -e /usr/include/sqlite3.h && echo "-tags libsqlite3")
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/testing/lxd/lxd.confd b/testing/lxd/lxd.confd
index ddc0a464175..68a521a1c11 100644
--- a/testing/lxd/lxd.confd
+++ b/testing/lxd/lxd.confd
@@ -1,7 +1,5 @@
-# Group which owns the shared socket
-LXD_OPTIONS=" --group lxd"
-
-
+# Group which owns the shared socket, used for unpriviledged containers
+#LXD_OPTIONS=" --group lxd"
# Enable cpu profiling into the specified file
#LXD_OPTIONS="${LXD_OPTIONS} --cpuprofile /tmp/lxc_cpu_profile"
@@ -9,8 +7,6 @@ LXD_OPTIONS=" --group lxd"
# Enable memory profiling into the specified file
#LXD_OPTIONS="${LXD_OPTIONS} --memprofile /tmp/lxc_mem_profile"
-
-
# Enables debug mode
#LXD_OPTIONS="${LXD_OPTIONS} --debug"