aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 18:26:46 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-09 15:35:12 +0000
commit2944053d792a084c2d0d62700f6238b7ea59f325 (patch)
treef24374b9c0ddd842e4c72c20b8dda59b064c07bd /testing
parent4e51a20739c61367ca0b5067e7c6a5000f04c0d6 (diff)
testing/fwknop: upgrade to 2.6.10
Diffstat (limited to 'testing')
-rw-r--r--testing/fwknop/APKBUILD52
1 files changed, 19 insertions, 33 deletions
diff --git a/testing/fwknop/APKBUILD b/testing/fwknop/APKBUILD
index b4ba86fdcb2..b98f74cd1b9 100644
--- a/testing/fwknop/APKBUILD
+++ b/testing/fwknop/APKBUILD
@@ -1,32 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fwknop
-pkgver=2.6.9
-pkgrel=2
+pkgver=2.6.10
+pkgrel=0
pkgdesc="A Single Packet Authorization (SPA) implementation"
url="http://www.cipherdyne.org/fwknop/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
depends="iptables"
-depends_dev=""
-makedepends="$depends_dev libpcap-dev iptables gpgme-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-server"
+makedepends="libpcap-dev iptables gpgme-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc $pkgname-server"
source="http://cipherdyne.org/fwknop/download/fwknop-$pkgver.tar.gz
fwknopd.initd"
-_builddir="$srcdir"/fwknop-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
- cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,19 +21,23 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --with-gpgme \
- || return 1
- make || return 1
+ --disable-static \
+ --with-gpgme
+ make
+}
+
+check() {
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/fwknopd.initd "$pkgdir"/etc/init.d/fwknopd
- echo "# If using gnupg2 see https://www.gnupg.org/faq/GnuPG-FAQ.html#how-can-i-use-gnupg-in-an-automated-environment" >> "$pkgdir"/etc/fwknop/access.conf
- echo "# & sign the client public key on the server with a normal key which has a password" >> "$pkgdir"/etc/fwknop/access.conf
- echo "# disable GPG_DECRYPT_PW & enable the following variable:" >> "$pkgdir"/etc/fwknop/access.conf
- echo "#GPG_ALLOW_NO_PW: Y;" >> "$pkgdir"/etc/fwknop/access.conf
+ cat <<- __EOF__ >> "$pkgdir"/etc/fwknop/access.conf
+ \# If using gnupg2 see https://www.gnupg.org/faq/GnuPG-FAQ.html#how-can-i-use-gnupg-in-an-automated-environment & sign the client public key on the server with a normal key which has a password"
+ \# disable GPG_DECRYPT_PW & enable the following variable:
+ \#GPG_ALLOW_NO_PW: Y;
+ __EOF__
}
server() {
@@ -57,9 +47,5 @@ server() {
&& mv "$pkgdir"/etc "$subpkgdir"/
}
-md5sums="f195bd31e7dc7df2e9b0c35cd80655b7 fwknop-2.6.9.tar.gz
-db52540eb534e34e839988f0d33d3abd fwknopd.initd"
-sha256sums="9022a0e1b3ee1dc9cd1323efcc0e5f8f24bc521e19e9779efd9d23a3aa3e5577 fwknop-2.6.9.tar.gz
-ac9da6eaf36eba551654efceab2f8c8f92cd0a7b4e308e8d6bfa87195d4a9c78 fwknopd.initd"
-sha512sums="25e17cd74eba088e1e341482b8c69ff781f4f2e0986fedbd0f52b5d1f99638087ed70de3994d05419e2541969d94d9e8fe7417d3df3449f683dab32b2565bfef fwknop-2.6.9.tar.gz
+sha512sums="3b3e35eda574abd1759431c88677eea7078c54cb3252c0ee0e1019b5b8224ed8844d30760da70a952e1cd92b04715a547f6effabda54678f791fff9afa32cd80 fwknop-2.6.10.tar.gz
e3558c4a1579ea66b19451acc476f3cfec782b052f6d96a57ffc520169db755739e2bf3a815802cc5958a7b2fdeb9b39cf2182e5d89882cf4502985401352465 fwknopd.initd"