aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-13 22:46:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-14 15:16:42 -0300
commit2ab0701aaf5b7aa3a8f4bab542f3a9b61c831053 (patch)
tree79be6273ae8104774f7c629a3cabbe29862f8bef /testing
parent39bafda66e100b67369e953efd9b2653909a1eeb (diff)
testing/plasma-pa: drop dependency on gconf
Diffstat (limited to 'testing')
-rw-r--r--testing/plasma-pa/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/plasma-pa/APKBUILD b/testing/plasma-pa/APKBUILD
index bbe8cda4a56..2d40a401dfd 100644
--- a/testing/plasma-pa/APKBUILD
+++ b/testing/plasma-pa/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
pkgver=5.16.3
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet for audio volume management using PulseAudio"
arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
depends="pulseaudio kirigami2"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev gconf-dev"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev"
source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
@@ -16,7 +16,8 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DUSE_GCONF=OFF
make
}