aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-03 23:40:45 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-04 02:18:37 +0100
commit37b3e161e2e7e45c9dd96024a24a99b1d39d9186 (patch)
treeb35f305e6cd3a7d8e602f18cf4b4aa47b918ac67 /testing
parentac42a180d78c01c1593f7ff070f2607f6ec9494d (diff)
testing/chatty: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/chatty/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/chatty/APKBUILD b/testing/chatty/APKBUILD
new file mode 100644
index 00000000000..fef57b563e9
--- /dev/null
+++ b/testing/chatty/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=chatty
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="A phone dialer and call handler"
+arch="all !s390x" # Blocked by libhandy and evolution
+url="https://gitlab.gnome.org/Community/Purism/chatty"
+license="GPL-3.0-or-later"
+depends="purple-mm-sms"
+makedepends="meson ninja gtk+3.0-dev pidgin-dev libhandy-dev evolution-dev libgee-dev folks-dev"
+source="$pkgname-$pkgver.tar.gz::https://source.puri.sm/Librem5/chatty/-/archive/v$pkgver/chatty-v$pkgver.tar.gz"
+subpackages="$pkgname-lang"
+builddir="$srcdir/$pkgname-v$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja install -C output
+}
+sha512sums="a3bf3cc3e0149193a46ad13c4c39d183c22bc3b7f104628f381c3d67a95d4eaf6962b264c31e4e8fea343c6f28ed429771ad529a497c1858f4ee81e2db370ec7 chatty-0.1.3.tar.gz"