aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-07 21:58:16 +0300
committerprspkt <prspkt@protonmail.com>2019-06-08 16:18:06 +0300
commit4860e891a3099f3bc8017b2aa4e3a62b74fd356d (patch)
tree47f89d6c899688b7c4adefea4ea430bb85d1f5d0 /testing
parent9c08c7c151e0ed614e93cecabf79b5c5582f1e1c (diff)
testing/py-sphinxcontrib-bitbucket: upgrade to python3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-sphinxcontrib-bitbucket/APKBUILD (renamed from testing/py-sphinxcontrib-bitbucket/APKBUILD)21
-rw-r--r--testing/py3-sphinxcontrib-bitbucket/fix-python3.patch30
2 files changed, 42 insertions, 9 deletions
diff --git a/testing/py-sphinxcontrib-bitbucket/APKBUILD b/testing/py3-sphinxcontrib-bitbucket/APKBUILD
index c7c5a53810e..0cdc105ee8f 100644
--- a/testing/py-sphinxcontrib-bitbucket/APKBUILD
+++ b/testing/py3-sphinxcontrib-bitbucket/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-bitbucket
+pkgname=py3-sphinxcontrib-bitbucket
_pkgname=sphinxcontrib-bitbucket
pkgver=1.0
pkgrel=0
@@ -8,12 +8,13 @@ pkgdesc="Sphinx BitBucket extension"
url="https://pypi.python.org/pypi/sphinxcontrib-bitbucket"
arch="noarch"
license="BSD"
-depends="python2 py-sphinx py-docutils"
+depends="py3-sphinx"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools"
install=""
subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ fix-python3.patch"
_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
@@ -26,16 +27,18 @@ prepare() {
done
}
+replaces="py-sphinxcontrib-bitbucket" # Backwards compatibility
+provides="py-sphinxcontrib-bitbucket=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="129147d406087e44769ae7320a2d839b sphinxcontrib-bitbucket-1.0.tar.gz"
-sha256sums="b717248b24d6e8b206397b5c3d9c5bd9cdd0c38a4ed6354549faff48e3155da1 sphinxcontrib-bitbucket-1.0.tar.gz"
-sha512sums="e018fceecc24b7a9656d57a9855c824665948f877394b7ca6b0f22473bf83492d4155a9c9960cf18e9b10268f2928d0762a4ad48ffee2ebb819275d563751e18 sphinxcontrib-bitbucket-1.0.tar.gz"
+sha512sums="e018fceecc24b7a9656d57a9855c824665948f877394b7ca6b0f22473bf83492d4155a9c9960cf18e9b10268f2928d0762a4ad48ffee2ebb819275d563751e18 sphinxcontrib-bitbucket-1.0.tar.gz
+4e98838a71d14f6b5b4ad1780617a2fd91470c8952e7ec9507dbc6ebb48bf4830d0f21bdca4aded10cf7979e6bd772113df326e9a9df4778176d1786cba999e2 fix-python3.patch"
diff --git a/testing/py3-sphinxcontrib-bitbucket/fix-python3.patch b/testing/py3-sphinxcontrib-bitbucket/fix-python3.patch
new file mode 100644
index 00000000000..dc32986fe83
--- /dev/null
+++ b/testing/py3-sphinxcontrib-bitbucket/fix-python3.patch
@@ -0,0 +1,30 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,5 @@
+ # -*- coding: utf-8 -*-
+
+-# Bootstrap installation of Distribute
+-import distribute_setup
+-distribute_setup.use_setuptools()
+-
+ from setuptools import setup, find_packages
+
+ try:
+@@ -43,5 +39,4 @@
+ include_package_data=True,
+ install_requires=requires,
+ namespace_packages=['sphinxcontrib'],
+- py_modules = [ 'distribute_setup' ],
+ )
+Only in src/: sphinxcontrib-bitbucket-1.0/setup.py.orig
+--- a/sphinxcontrib/bitbucket.py
++++ b/sphinxcontrib/bitbucket.py
+@@ -23,7 +23,7 @@
+ base = app.config.bitbucket_project_url
+ if not base:
+ raise AttributeError
+- except AttributeError, err:
++ except AttributeError as err:
+ raise ValueError('bitbucket_project_url configuration value is not set (%s)' % str(err))
+ #
+ slash = '/' if base[-1] != '/' else ''