aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-19 14:31:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-19 15:06:47 +0200
commit56a6406c37548068ae2d84e5ad7b9dfe9da308da (patch)
tree581cf3ae50ce7561b34c545820ab343ec901c103 /testing
parentf9d9a8122ada529e8653fe21f122f079897d8c79 (diff)
testing/py-django-south: improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/py-django-south/APKBUILD37
1 files changed, 14 insertions, 23 deletions
diff --git a/testing/py-django-south/APKBUILD b/testing/py-django-south/APKBUILD
index cf253e8bb86..622cf272fd3 100644
--- a/testing/py-django-south/APKBUILD
+++ b/testing/py-django-south/APKBUILD
@@ -1,37 +1,28 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer:
pkgname=py-django-south
+_pkgname=South
pkgver=0.8.4
-pkgrel=0
+pkgrel=1
pkgdesc="Migrations for Django"
-url=http://south.aeracode.org/
-arch=noarch
-license=BSD
-depends=py-django
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/S/South/South-$pkgver.tar.gz"
-
-_builddir=$srcdir/South-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+url="http://south.aeracode.org/"
+arch="noarch"
+license="BSD"
+depends="py-django"
+makedepends="py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./setup.py build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
./setup.py install --root "$pkgdir"
}
-md5sums="ccd6ebadd3e2c8c6ef16d771632f7840 South-0.8.4.tar.gz"
-sha256sums="5cf6bdc2967be8dd7845d3058e3af0a73408e5383c9effc3123bb48c3cc5c821 South-0.8.4.tar.gz"
-sha512sums="5d01605aac6feffb9423137f1db7cf599e0bb6417e8fa3735e1c5c9fdf6c22bd0658d4daac92d4a04594632a5e68750916331200fbd76f0d1fb3e47bb5e91adb South-0.8.4.tar.gz"
+md5sums="ccd6ebadd3e2c8c6ef16d771632f7840 py-django-south-0.8.4.tar.gz"
+sha256sums="5cf6bdc2967be8dd7845d3058e3af0a73408e5383c9effc3123bb48c3cc5c821 py-django-south-0.8.4.tar.gz"
+sha512sums="5d01605aac6feffb9423137f1db7cf599e0bb6417e8fa3735e1c5c9fdf6c22bd0658d4daac92d4a04594632a5e68750916331200fbd76f0d1fb3e47bb5e91adb py-django-south-0.8.4.tar.gz"