aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-12 08:03:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 08:21:20 -0300
commit5f2950e81b41f53158f6a9b3dabb7e8fa65a91f3 (patch)
treefebc2782bd3ba68e03e318033f2ef9918ade1a8f /testing
parentb9a939ff7e2f100830041c6b1b6887d1b558c28c (diff)
testing/iprange: upgrade to 1.0.4
Diffstat (limited to 'testing')
-rw-r--r--testing/iprange/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/testing/iprange/APKBUILD b/testing/iprange/APKBUILD
index 895d60a6c19..ed47c48e96f 100644
--- a/testing/iprange/APKBUILD
+++ b/testing/iprange/APKBUILD
@@ -1,23 +1,23 @@
# Contributor: Jonny Tyers <jtyers@gmail.com>
# Maintainer: Jonny Tyers <jtyers@gmail.com>
pkgname=iprange
-pkgver=1.0.3
+pkgver=1.0.4
pkgrel=0
pkgdesc="manages IP ranges (part of FireHOL)"
url="https://github.com/firehol/iprange"
arch="all"
-license="GPL-2.0"
-depends=""
-install=""
+license="GPL-2.0-or-later"
+makedepends="autoconf automake libtool help2man"
subpackages="$pkgname-doc"
-source="https://firehol.org/download/iprange/releases/v$pkgver/iprange-$pkgver.tar.bz2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/firehol/iprange/archive/v$pkgver.tar.gz"
options="!check"
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,13 +25,13 @@ build() {
--sysconfdir=/etc/ssh \
--datadir=/usr/share/openssh \
--libexecdir=/usr/lib/ssh \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man \
+ --enable-maintainer-mode
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="c3da3b0f070010e53d2caa53cf0f11d5a8691ead418f2549c837a287cc8cbd023f36fa85eb7740ddc5df5339f103107cf3be02f6ee1489e160cba10692f9e0e1 iprange-1.0.3.tar.bz2"
+sha512sums="c72bdc71a2bf24e4c17bb2267220e11d09afd5c728b0e929c718e8103ed4d96a9620c559fe6d955e3d688f3c7a989510897c444d3ad9a5369aa93150e68177f3 iprange-1.0.4.tar.gz"