aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 14:37:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commit6468648c4e226d39d7b594747b562c39695ed0e0 (patch)
tree8295903c0157c7fb07d3908d3092642128d4e8a4 /testing
parent03991ee7345c37464f80883ddc95390f20f38a90 (diff)
testing/py3-flake8-blind-except: upgrade to 0.1.1
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-flake8-blind-except/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/testing/py3-flake8-blind-except/APKBUILD b/testing/py3-flake8-blind-except/APKBUILD
index f83f133fd17..f6cc1fc8af6 100644
--- a/testing/py3-flake8-blind-except/APKBUILD
+++ b/testing/py3-flake8-blind-except/APKBUILD
@@ -1,28 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flake8-blind-except
+pkgname=py3-flake8-blind-except
_pkgname=flake8-blind-except
-pkgver=0.1.0
-pkgrel=4
+pkgver=0.1.1
+pkgrel=0
pkgdesc="Extension for flake8 which checks for blind except: statements"
+options="!check" # No testsuite
url="https://github.com/elijahandrews/flake8-blind-except"
arch="noarch"
license="MIT"
-depends="flake8"
-makedepends="python3-dev"
+depends="py3-flake8 py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-flake8-blind-except" # Backwards compatibility
+provides="py-flake8-blind-except=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="a76ae6603b53c230ad81f9dea27c6bbb flake8-blind-except-0.1.0.tar.gz"
-sha256sums="a8599a48d9fff490ce4fa2c6a60ca876c39cc6c107f58068eb831079266b650b flake8-blind-except-0.1.0.tar.gz"
-sha512sums="4fc3d284309fdb12eff7c50710b25958d180dfee1f34e5bcd48d08ee5310514806fc972ca0d516053b25327d84476d7e6badf6ca2e709c3c888239004647501f flake8-blind-except-0.1.0.tar.gz"
+sha512sums="3a74e626b87e570a079dd54ac4abbdabf2daa0b5bc64b8205f54747ddb8ce8dd4ded9dd3222307f879dcda8fc9aa47dcfacf401da27d7717888cd3d9691a0513 flake8-blind-except-0.1.1.tar.gz"