aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-08-05 19:30:45 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-08-12 14:20:16 +0300
commit7354c1327c059a136760d2aa71bbcd1fbb3a0ca1 (patch)
tree9fc88538976bb935a106bc35740a75411c0a199d /testing
parent253c2462d8aaee6484004d988fb93a898e9cf0a8 (diff)
testing/php7-pecl-swoole: enable ppc64le and s390x via libucontext
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
index fb622d8039c..30aa9f4f0d0 100644
--- a/testing/php7-pecl-swoole/APKBUILD
+++ b/testing/php7-pecl-swoole/APKBUILD
@@ -2,19 +2,22 @@
pkgname=php7-pecl-swoole
_pkgreal=swoole
pkgver=4.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
url="https://pecl.php.net/package/swoole"
-arch="all !ppc64le !s390x" # Fails to build
+arch="all"
license="Apache-2.0"
depends="php7-openssl php7-sockets"
-makedepends="php7-dev autoconf re2c openssl-dev nghttp2-dev"
+makedepends="php7-dev autoconf re2c openssl-dev nghttp2-dev libucontext-dev"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
subpackages="$pkgname-dev"
build() {
cd "$builddir"
+ case "$CARCH" in
+ ppc64le|s390x) export LDFLAGS="$LDFLAGS -lucontext" ;;
+ esac
phpize7
./configure --prefix=/usr \
--with-php-config=php-config7 \