aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-25 20:12:22 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-25 20:12:22 +0200
commit7ef01101d87f54b480069a11a517fe1260886733 (patch)
tree8a9b0ba27174c675a4cb280e9c2b0796123ec912 /testing
parent924e341f49dd180662ea0a451a05882edc5edbed (diff)
community/cunit: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/cunit/APKBUILD55
-rw-r--r--testing/cunit/path-makefile.patch31
2 files changed, 0 insertions, 86 deletions
diff --git a/testing/cunit/APKBUILD b/testing/cunit/APKBUILD
deleted file mode 100644
index 7433118af37..00000000000
--- a/testing/cunit/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=cunit
-_pkgname=CUnit
-pkgver=2.1.3
-_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=0
-pkgdesc="Automated testing framework for C"
-url="http://cunit.sourceforge.net/"
-arch="all"
-license="GPL2"
-options="!check"
-makedepends="automake autoconf libtool bash"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
- path-makefile.patch"
-builddir="$srcdir/$_pkgname-$_pkgver"
-
-prepare() {
- cd "$builddir"
- libtoolize --force --copy
- aclocal
- autoheader
- automake --add-missing --include-deps --copy
- autoconf
-}
-
-build() {
- cd "$builddir"
- default_prepare
- ./configure \
- --prefix=/usr \
- --includedir=/usr/include \
- --datarootdir=/usr/share \
- --libdir=/usr/lib \
- --enable-debug \
- --enable-examples \
- --enable-automated \
- --enable-basic \
- --enable-test \
- --disable-static
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="b5f1a9f6093869c070c6e4a9450cc10c CUnit-2.1-3.tar.bz2
-975cfef465755b6cc5b946afb8dfcdd0 path-makefile.patch"
-sha256sums="f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214 CUnit-2.1-3.tar.bz2
-229dc40fdbbd918a9349f8c8bd49e0962de32ab6e249776c30661424a363c5f4 path-makefile.patch"
-sha512sums="547b417109332446dfab8fda17bf4ccd2da841dc93f824dc90a20635bcf1fb80fb2176500d8a0906940f3f3d3e2f77b2d70a71090c9ab84ad9af43f3582bc487 CUnit-2.1-3.tar.bz2
-94b9ef959ff9808c6adb2022a8c085232bc3ca0d5023584a13c35c6cb17b98674b7cc252d65d53a5b3db085f82853463ade7f9b910b564befe1d7b1e868de105 path-makefile.patch"
diff --git a/testing/cunit/path-makefile.patch b/testing/cunit/path-makefile.patch
deleted file mode 100644
index a55bcd1dc8a..00000000000
--- a/testing/cunit/path-makefile.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/doc/Makefile.am b/doc/Makefile.am
-index a864d46..1c15fc0 100644
---- a/doc/Makefile.am
-+++ b/doc/Makefile.am
-@@ -1,6 +1,6 @@
- ## Process this file with automake to produce Makefile.in
-
--docdir = $(prefix)/doc/@PACKAGE@
-+docdir = $(datarootdir)/doc/@PACKAGE@
-
- doc_DATA = \
- CUnit_doc.css \
-@@ -13,4 +13,4 @@ doc_DATA = \
- test_registry.html \
- writing_tests.html
-
--SUBDIRS = headers
-\ No newline at end of file
-+SUBDIRS = headers
-diff --git a/doc/headers/Makefile.am b/doc/headers/Makefile.am
-index 9926e8b..3c5f1ba 100644
---- a/doc/headers/Makefile.am
-+++ b/doc/headers/Makefile.am
-@@ -1,6 +1,6 @@
- ## Process this file with automake to produce Makefile.in
-
--dochdrdir = $(prefix)/doc/@PACKAGE@/headers
-+dochdrdir = $(includedir)/@PACKAGE@/headers
-
- INCLUDE_FILES = \
- Automated.h \