aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-01-09 05:31:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-01-15 12:06:38 +0000
commit7f56449efe4bee3a71e3f37be0b9d92a1511d714 (patch)
tree3eafe3c08340497c512a2ae572c50255352e30b5 /testing
parent810b2b4cab3aad63cb338988d9d976012b6ad062 (diff)
testing/lldb: upgrade to 5.0.2
Use source URL as listed at http://releases.llvm.org/download.html#5.0.2 Also list architectures explicitly, this is still shorter than excluding all mips variants.
Diffstat (limited to 'testing')
-rw-r--r--testing/lldb/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/lldb/APKBUILD b/testing/lldb/APKBUILD
index 12138fc6344..96d5dba63f5 100644
--- a/testing/lldb/APKBUILD
+++ b/testing/lldb/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer:
pkgname=lldb
# Note: Update together with llvm.
-pkgver=5.0.1
-pkgrel=1
+pkgver=5.0.2
+pkgrel=0
_vermajor=${pkgver%%.*}
pkgdesc="Next generation, high-performance debugger"
-arch="all !x86 !ppc64le"
+arch="aarch64 armhf armv7 s390x x86_64"
url="https://llvm.org/"
license="UOI-NCSA"
makedepends="
@@ -26,7 +26,7 @@ makedepends="
swig
"
subpackages="$pkgname-dev py2-$pkgname:py2"
-source="https://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz
+source="https://releases.llvm.org/$pkgver/$pkgname-$pkgver.src.tar.xz
musl-include-ptrace.aarch64.patch
cmake-include-ClangConfig.patch
fix-embedded_interpreter.patch
@@ -83,7 +83,7 @@ py2() {
python2 -m compileall -fqd /$sitedir $sitedir
}
-sha512sums="ebb3c3251098cfce28ccb6a5bbc50491a16b88d1adf3c71fd38efc95482d702e1bd9e7fb11c29597304d97cc0fd88241c70ec11276426aad901e5d23f05ca53a lldb-5.0.1.src.tar.xz
+sha512sums="66eaaead60cc908ac061bedb4fac9cb96cecb7f4e5a79a51b6fa080e8f61f718b14e5f3581ead832b495bf10f055d4253d199236a0947dd22395ec80bf2afcf4 lldb-5.0.2.src.tar.xz
1613a1cb042edd430aba6b86e4971ebb01f7d2bc3f13a5a1264cb94da7612188897e9dcaaa9233be8af5c8f4bad013dd0cfb821e323cd73dfe07fe125869ccef musl-include-ptrace.aarch64.patch
18ea4cd3ef357299833e243613031ad67ff82f7c93c1f3fbe2cbce8876ffeec2d8ff2f94c8242ea540c2604ffbc023fb2678643fc9d3b64231f096054d186aef cmake-include-ClangConfig.patch
3c611fa5d45b6cb3f2925a31deeb8a34c295277aedcd55c22851d373897acd376fa92f4ef953c96a25c8dae4c93b6a88de0918550672141d324a3813d8283d48 fix-embedded_interpreter.patch"