aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:39 +0000
commit85402c773234bc3c667fda98f70410092e26eac1 (patch)
tree3067c0d4ac71759c92e93ac1d4f781cf2691ebcb /testing
parent52bab007ba88646684e810c76037f008725759db (diff)
testing/py-fixtures: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py-fixtures/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py-fixtures/APKBUILD b/testing/py-fixtures/APKBUILD
new file mode 100644
index 00000000000..9e1b280026c
--- /dev/null
+++ b/testing/py-fixtures/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-fixtures
+_pkgname=fixtures
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Useful extra bits for Python - things that shold be in the standard library"
+url="https://pypi.python.org/pypi/fixtures/"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="e52ba864c42d15a8baa60583761006b2dd78e3cd5f3f043f5702346aef428b933d62e8fa5889b7cb4196e4072acc5df3b7ffa39702a1b782887bdc109299b695 fixtures-3.0.0.tar.gz"