aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:13:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 04:24:58 -0300
commit902518c377adf823099a7784fad20e88cc250ae3 (patch)
tree4eff6c247cd86a0944574c205e76ef27547df5e1 /testing
parentaa8588fa12e77adab40c3fcb4d813da7a26bf0c9 (diff)
testing/py3-pygithub: upgrade to 1.43.8
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pygithub/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/testing/py3-pygithub/APKBUILD b/testing/py3-pygithub/APKBUILD
index 17f6b40f11c..fbb4dc19eb5 100644
--- a/testing/py3-pygithub/APKBUILD
+++ b/testing/py3-pygithub/APKBUILD
@@ -2,32 +2,29 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-pygithub
_pkgname=PyGithub
-pkgver=1.40
-pkgrel=1
+pkgver=1.43.8
+pkgrel=0
pkgdesc="Typed interactions with the GitHub API v3"
url="https://github.com/PyGithub/PyGithub"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="python3 py3-jwt py3-requests"
-makedepends="python3-dev py3-setuptools"
+depends="python3 py3-jwt py3-requests py3-deprecated"
+makedepends="py3-setuptools"
+checkdepends="py3-httpretty py3-cryptography"
source="https://github.com/PyGithub/PyGithub/archive/v$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
+ python3 -m lib2to3 -w -n tests
python3 setup.py test
}
package() {
- cd "$builddir"
-
python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -R "$pkgdir"/usr/lib/python3.*/site-packages/github/tests
}
-sha512sums="e8719017ce04db2c25ab8059b124a43a3688d4775861b80a0bcc7a194eaf43cd942eba1da199b76ef35c5bcde364708586c09630a7fac5642867b5a62985efad PyGithub-1.40.tar.gz"
+sha512sums="dc58166ebb27f855ed4f32448029abe7e53b8050d8d99029d460f2dd94180ca8bcef68a75469293abd021f70cc3c67c32061e6439db1b3f1dc77af464c658bb6 PyGithub-1.43.8.tar.gz"