aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2019-01-12 10:06:46 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-12 11:41:15 +0000
commit96a4b82036347b0908f035b682035adc6a6cdedc (patch)
tree5a28e9f5743733e80603732341c38250f86d7280 /testing
parent51771d65ca85865b55c3b4a63cdcfe7ca4983b0e (diff)
testing/alsa-plugins/APKBUILD -> community/alsa-plugins:
* Upgrade to 1.1.8 * Move from testing * Include corresponding config files to subpackages * Cosmetic changes
Diffstat (limited to 'testing')
-rw-r--r--testing/alsa-plugins/APKBUILD77
-rw-r--r--testing/alsa-plugins/alsa-plugins-1.1.7-double_free_fix.patch31
2 files changed, 0 insertions, 108 deletions
diff --git a/testing/alsa-plugins/APKBUILD b/testing/alsa-plugins/APKBUILD
deleted file mode 100644
index 17e734cc88e..00000000000
--- a/testing/alsa-plugins/APKBUILD
+++ /dev/null
@@ -1,77 +0,0 @@
-# Maintainer: Taner Tas <taner76@gmail.com>
-pkgname=alsa-plugins
-pkgver=1.1.7
-pkgrel=2
-pkgdesc="Advanced Linux Sound Architecture (ALSA) plugins"
-url="http://www.alsa-project.org"
-arch="all !s390x"
-license="GPL-2.0-or-later LGPL-2.1-or-later"
-makedepends="linux-headers alsa-lib-dev speex-dev ffmpeg-dev libsamplerate-dev pulseaudio-dev jack-dev"
-subpackages="$pkgname-pulse $pkgname-doc $pkgname-lavrate $pkgname-a52 $pkgname-jack"
-source="ftp://ftp.alsa-project.org/pub/plugins/$pkgname-$pkgver.tar.bz2
- $pkgname-$pkgver-double_free_fix.patch"
-
-prepare() {
- default_prepare
- update_config_sub
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
-}
-
-check(){
- cd "$builddir"
- make check
-}
-
-doc() {
- default_doc
- mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
- cat > "$subpkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
- ==> please note that alsa-plugins-lavcrate has been renamed to lavrate.
- ==> So you need to run: apk add alsa-plugins-lavrate
-EOF
-}
-
-lavrate() {
- pkgdesc="FFmpeg samplerate conversion plugins for alsa"
- mkdir -p "$subpkgdir"/usr/lib/alsa-lib/
- mv "$pkgdir"/usr/lib/alsa-lib/*lavrate* "$subpkgdir"/usr/lib/alsa-lib/
-}
-
-pulse() {
- pkgdesc="Pulseaudio support plugins for alsa-only applications"
- mkdir -p "$subpkgdir"/usr/lib/alsa-lib/
- mv "$pkgdir"/usr/lib/alsa-lib/*pulse.so "$subpkgdir"/usr/lib/alsa-lib/
- mv "$pkgdir"/usr/share "$subpkgdir"/usr/
-}
-
-a52() {
- pkgdesc="Converts S16 linear sound format to A52 compressed format and sends it to an SPDIF output"
- mkdir -p "$subpkgdir"/usr/lib/alsa-lib/
- mv "$pkgdir"/usr/lib/alsa-lib/*a52.so "$subpkgdir"/usr/lib/alsa-lib/
-}
-
-jack() {
- pkgdesc="Allows native ALSA applications to work with jackd"
- mkdir -p "$subpkgdir"/usr/lib/alsa-lib/
- mv "$pkgdir"/usr/lib/alsa-lib/*jack.so "$subpkgdir"/usr/lib/alsa-lib/
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- find $pkgdir -name *.la -type f -exec rm -f {} \;
-}
-
-sha512sums="c3bb22ec3c5a167fb246cfc94131d53800e321b486ab743c3395a9d91dee0ff9703f6e4a2feaea5a4ee42a7e486d835d48ab880c784c5c34bb4eb5e9ded06d8e alsa-plugins-1.1.7.tar.bz2
-a57d1fe16ac51bd3010ba9ee705bd4d32e339f5f35ff7388910ecf0b8024d491d38a573a730f0a5a640cb688d7fadac05ca1e0162a08beb397e7fc0883c15a25 alsa-plugins-1.1.7-double_free_fix.patch"
diff --git a/testing/alsa-plugins/alsa-plugins-1.1.7-double_free_fix.patch b/testing/alsa-plugins/alsa-plugins-1.1.7-double_free_fix.patch
deleted file mode 100644
index f62ede8be20..00000000000
--- a/testing/alsa-plugins/alsa-plugins-1.1.7-double_free_fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Jaroslav Kysela <perex@perex.cz>
-Date: Tue, 23 Oct 2018 07:32:46 +0000 (+0200)
-Subject: a52_close: set slave to NULL to avoid double pcm free in open fcn
-X-Git-Tag: v1.1.8~19
-X-Git-Url: http://git.alsa-project.org/?p=alsa-plugins.git;a=commitdiff_plain;h=a4e7e1282c57a2f4e83afe9a4008042d8b4c5bb9
-
-a52_close: set slave to NULL to avoid double pcm free in open fcn
-
-Signed-off-by: Jaroslav Kysela <perex@perex.cz>
----
-
-diff --git a/a52/pcm_a52.c b/a52/pcm_a52.c
-index e431fd0..b005bc2 100644
---- a/a52/pcm_a52.c
-+++ b/a52/pcm_a52.c
-@@ -654,10 +654,13 @@ static int a52_poll_revents(snd_pcm_ioplug_t *io, struct pollfd *pfd,
- static int a52_close(snd_pcm_ioplug_t *io)
- {
- struct a52_ctx *rec = io->private_data;
-+ snd_pcm_t *slave = rec->slave;
-
- a52_free(rec);
-- if (rec->slave)
-- return snd_pcm_close(rec->slave);
-+ if (slave) {
-+ rec->slave = NULL;
-+ return snd_pcm_close(slave);
-+ }
- return 0;
- }
-