aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2019-04-08 21:50:41 -0400
committerAndy Postnikov <apostnikov@gmail.com>2019-04-10 13:49:54 +0300
commit997fb3097e31361e41795a01ea25177aa44bc51b (patch)
tree4cb98a0bb1ec16714f2bccb88abd8f2047ca90b3 /testing
parentc9693baa78dccbc0543a8996287f2696b3d99971 (diff)
testing/minio: upgrade to 0.20190409
BREAKING: minio has moved to the go1.11 module system. This requires new abuild features (present in ~3.4) to handle without failures (see: cleanup_srcdir and related history). Besides that, this is a major security release (and a minor bugfix release that happened while waiting on abuild 3.4).
Diffstat (limited to 'testing')
-rw-r--r--testing/minio/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/minio/APKBUILD b/testing/minio/APKBUILD
index 1342b66994b..1c169d8aa10 100644
--- a/testing/minio/APKBUILD
+++ b/testing/minio/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=minio
-_pkgver='RELEASE.2019-03-27T22-35-21Z'
+_pkgver='RELEASE.2019-04-09T01-22-30Z'
pkgver=${_pkgver#*.}
pkgver=${pkgver%T*}
pkgver=0.${pkgver//-}
@@ -36,7 +36,7 @@ prepare() {
build() {
cd "$builddir"
local _ldflags=$(go run buildscripts/gen-ldflags.go 2> /dev/null)
- go build -tags kqueue --ldflags "$_ldflags" -o bin/minio
+ GO111MODULE=on go build -tags kqueue --ldflags "$_ldflags" -o bin/minio
}
check() {
@@ -53,6 +53,11 @@ package() {
"$pkgdir"/etc/conf.d/"$pkgname"
}
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
sha512sums="18e55dc143c0d71afa8ba758de2efde40946704de65d7a53bfb5f2162fedc736a3f596d0fa75e514cb615e3bbf65809a60bd4b1c2fa22be39d18613d7ab42395 minio.initd
ed9790fbadfb38e4d660eb1befd87e803d70dec04d936e8cd26def4a9c21240bb7cae8750ae3395aa4761e6738b9e346c86ba57761cfde30efe46d2cb459a7e4 minio.confd
-1fce454f0cbbb90bd8fff48c20a3a93cac464ea8dda1acb5687a566a5db641e912ff57a9b8e73192df5a7eb896f265945da734f89cf6c57dc9e2a0c8554f8d10 RELEASE.2019-03-27T22-35-21Z.tar.gz"
+dd056bc5317911a49b6fcf1442c94fad0aca1b699605c0d4346aa164cb330b7cb3863f5d68197c453af8c6d3c8541ba92e0b382914dc5a4829ffd8e2db4e9c7d RELEASE.2019-04-09T01-22-30Z.tar.gz"