aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-05-29 12:14:01 +0000
committerpsykose <alice@ayaya.dev>2022-05-29 14:14:01 +0200
commit9fbb6a449fb9c562bfe38d89b04f700c47b103ae (patch)
tree4b5f589c5ccea6d6299fd607448e25ca1486158e /testing
parent4122f0fbb3fcbf2aae15ec21dd5890649189c583 (diff)
testing/dora: disable werror
Diffstat (limited to 'testing')
-rw-r--r--testing/dora/APKBUILD5
-rw-r--r--testing/dora/no-werror.patch8
2 files changed, 12 insertions, 1 deletions
diff --git a/testing/dora/APKBUILD b/testing/dora/APKBUILD
index 4337960466d..262e0c598cd 100644
--- a/testing/dora/APKBUILD
+++ b/testing/dora/APKBUILD
@@ -8,7 +8,9 @@ url="https://github.com/glitchub/dora"
arch="all"
license="MIT"
makedepends="linux-headers"
-source="https://github.com/glitchub/dora/archive/$_gitrev/dora-$_gitrev.tar.gz"
+source="https://github.com/glitchub/dora/archive/$_gitrev/dora-$_gitrev.tar.gz
+ no-werror.patch
+ "
builddir="$srcdir/$pkgname-$_gitrev"
options="!check" # no tests
@@ -22,4 +24,5 @@ package() {
sha512sums="
9c294b5d240c4c37e4bc70757b4d2ac2bf5d9d441ea904a1ae92b609abb055c62a054ae6dd525b5c5de9ae7dd484b972c05cd79b186b9f4748e8da8219fd586c dora-548aa8fad4c36de12944ce1210260f175d7eba59.tar.gz
+84b99846110e5217564b350534edc8f7ebf49cd0be3ed087580b4758fd4ebb5dcdc9f3e553ce25db47b8215d66241ba6ac4fe585a9a2ff79c0449f7dca96eaa4 no-werror.patch
"
diff --git a/testing/dora/no-werror.patch b/testing/dora/no-werror.patch
new file mode 100644
index 00000000000..b4224686786
--- /dev/null
+++ b/testing/dora/no-werror.patch
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-override CFLAGS += -Wall -Werror -Os -s -Wno-format-truncation
++override CFLAGS += -Wall -Os -s -Wno-format-truncation
+
+ default: dora
+