aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-05 13:50:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 17:04:46 +0000
commitb3fae67f8ce59f423cd6f8ea5f1aeb87da0e28ed (patch)
treefbf2291c0f98963179aab479b48124be54474b05 /testing
parent38ee3ee2120f3dcd4045f8689b264f20db138923 (diff)
testing/libretro-beetle-ngp: new aport
https://github.com/libretro/libretro-beetle-ngp standalone port of Mednafen NGP to the libretro API
Diffstat (limited to 'testing')
-rw-r--r--testing/libretro-beetle-ngp/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-beetle-ngp/APKBUILD b/testing/libretro-beetle-ngp/APKBUILD
new file mode 100644
index 00000000000..f7c99963831
--- /dev/null
+++ b/testing/libretro-beetle-ngp/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-beetle-ngp
+pkgver=0_git20200130
+pkgrel=0
+_commit="6f15532b6ad17a2d5eb9dc8241d6af62416e796b"
+pkgdesc="standalone port of Mednafen NGP to the libretro API"
+url="https://github.com/libretro/libretro-beetle-ngp"
+arch="all"
+license="GPL-2.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/beetle-ngp-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/beetle-ngp-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 mednafen_ngp_libretro.so "$pkgdir"/usr/lib/libretro/mednafen_ngp_libretro.so
+}
+
+sha512sums="f0aa1f2096ef9f17121018215c52850205f4d553553e66341f4c5604982ca16fe486c74c62043775eda74be72f92d64b73672a6afedccb7a02ccef04595c0099 libretro-beetle-ngp-6f15532b6ad17a2d5eb9dc8241d6af62416e796b.tar.gz"