aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorArthur Jones <arthur.jones@riverbed.com>2018-08-22 14:36:12 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-30 15:33:02 +0000
commitb59f1ba19925bb222f1dd525700e8d1111a9dd1d (patch)
tree59c8a321f14551cdcbcff4fc391ee79433268153 /testing
parente61564dda2e21800fa6cbd4824aa0808f9cd6ae8 (diff)
testing/frr: set /etc/frr to be owned by frr:frr
Currently, /etc/frr is owned by root, but when re-writing config with command like: router# copy running-config startup-config we fail as we drop down to frr:frr when writing config. Here, we chown -R frr:frr /etc/frr to make sure we can re-write config safely Fixes: #9328
Diffstat (limited to 'testing')
-rw-r--r--testing/frr/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/testing/frr/APKBUILD b/testing/frr/APKBUILD
index 2333eeeeb37..150a4f0256f 100644
--- a/testing/frr/APKBUILD
+++ b/testing/frr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Arthur Jones <arthur.jones@riverbed.com>
pkgname=frr
pkgver=5.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="FRRouting is a fork of quagga"
pkgusers="frr"
pkggroups="frr"
@@ -65,6 +65,7 @@ package() {
install -Dm644 "$builddir"/tools/etc/frr/daemons "$pkgdir"$_sysconfdir
install -Dm644 "$builddir"/tools/etc/frr/daemons.conf "$pkgdir"$_sysconfdir
+ chown -R ${pkgusers%% *}:${pkggroups%% *} "$pkgdir"$_sysconfdir
install -Dm755 "$srcdir"/frr.initd "$pkgdir"/etc/init.d/frr.initd
}