aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2021-09-17 02:25:09 +0200
committerMichał Polański <michal@polanski.me>2021-09-17 02:25:09 +0200
commitb5f48b4bc60d2d47df4c5940979edcbb985226cf (patch)
tree27b8fa48fec99e65d7786b19ff8348ab3c2f1d7b /testing
parent9ab826630eb55d965118a4cd7e65f1dc398e09ce (diff)
testing/fatrace: new aport
Report system wide file access events https://github.com/martinpitt/fatrace
Diffstat (limited to 'testing')
-rw-r--r--testing/fatrace/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/fatrace/APKBUILD b/testing/fatrace/APKBUILD
new file mode 100644
index 00000000000..cc3ae1d777a
--- /dev/null
+++ b/testing/fatrace/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=fatrace
+pkgver=0.16.3
+pkgrel=0
+pkgdesc="Report system wide file access events"
+url="https://github.com/martinpitt/fatrace"
+license="GPL-3.0-or-later"
+arch="all"
+depends="python3 powertop"
+subpackages="$pkgname-doc"
+source="https://github.com/martinpitt/fatrace/archive/$pkgver/fatrace-$pkgver.tar.gz"
+options="!check" # tests require root privileges
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="
+54ffcf4da48c0bd43373322d29352dfd50d8bd0cff8bba172ec30881fcdc4fa9fa3bcdcb86396331baada42ec87a03b4005b4d1a1c95e4e5c947395a80b61839 fatrace-0.16.3.tar.gz
+"