aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPellegrino Prevete <pellegrinoprevete@gmail.com>2020-06-28 14:53:28 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-14 06:54:32 +0000
commitb7492170c8651f2ac516ca07519599b5c045bf2d (patch)
tree893a26148d050b3feca27989bd1834c6608baa30 /testing
parentfc94e5f20ffac686d073a5773f3b76f1fc106055 (diff)
testing/lollypop: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/lollypop/APKBUILD42
-rw-r--r--testing/lollypop/dont-require-py3-gettext-support.patch15
2 files changed, 57 insertions, 0 deletions
diff --git a/testing/lollypop/APKBUILD b/testing/lollypop/APKBUILD
new file mode 100644
index 00000000000..f65b9e3bce0
--- /dev/null
+++ b/testing/lollypop/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+pkgname=lollypop
+pkgver=1.3.2
+# See the git submodule in subprojects/po for the right version
+_pover=418a3682e8372d08ed0955db37f6b23d5cc7db9c
+pkgrel=0
+pkgdesc="Music player for GNOME"
+url="https://gitlab.gnome.org/World/Lollypop"
+arch="noarch !s390x" # libhandy missing
+license="GPL-3.0-only"
+depends="python3 libhandy py3-cairo py3-gobject3 py3-pillow py3-pylast"
+makedepends="gobject-introspection-dev gtk+3.0-dev libhandy-dev libsoup-dev
+ meson py3-gobject3-dev"
+checkdepends="appstream-glib desktop-file-utils"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://gitlab.gnome.org/World/lollypop/-/archive/$pkgver/lollypop-$pkgver.tar.gz
+ https://gitlab.gnome.org/gnumdk/lollypop-po/-/archive/$_pover/lollypop-po-$_pover.tar.gz
+ dont-require-py3-gettext-support.patch
+ "
+
+prepare() {
+ default_prepare
+
+ mv $srcdir/lollypop-po*/* $srcdir/lollypop-$pkgver/subprojects/po/
+}
+
+build() {
+ abuild-meson . output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="1a2311195c62d46cf558b840541089fac419700be28a1a0c8b1eea872defc07b288b7fa53c93746ac480e91379959a357a286c0d66f970180a14272ea1ac8663 lollypop-$pkgver.tar.gz
+5b7a262fec81704ae41d4c498fc98bf0cd9b4e477debb0707106df044ba900cdc5392712f7c31d2a4a81e2f06188dc5049416b755c1aed37cdbf973b0472ebf8 lollypop-po-418a3682e8372d08ed0955db37f6b23d5cc7db9c.tar.gz
+94610ee386d5e6102b3cb0e86dbe4303d928f02a1aad6c0697a7d8c2e9c135cc65932b40ba53c5d0446ad17c097f7d900a8e0a8bea533df31b55cbe3ddca47df dont-require-py3-gettext-support.patch"
diff --git a/testing/lollypop/dont-require-py3-gettext-support.patch b/testing/lollypop/dont-require-py3-gettext-support.patch
new file mode 100644
index 00000000000..aa58a0a16aa
--- /dev/null
+++ b/testing/lollypop/dont-require-py3-gettext-support.patch
@@ -0,0 +1,15 @@
+Author: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+Summary: fix missing locale in Alpine
+----
+
+--- lollypop-1.3.2/lollypop.in.orig
++++ lollypop-1.3.2/lollypop.in
+@@ -34,8 +34,6 @@
+ if __name__ == "__main__":
+ install_excepthook()
+
+- locale.bindtextdomain('lollypop', localedir)
+- locale.textdomain('lollypop')
+ gettext.bindtextdomain('lollypop', localedir)
+ gettext.textdomain('lollypop')
+